AVR Dragon: 目次

このﾍﾙﾌﾟは一般の方々の便宜のため有志により作成されたもので、ATMEL社とは無関係であることを御承知ください。また、留意点も参照してください。

AVR Dragon 使用者の手引き 4.19J0

目次

序文

1. 導入
2. 開始に際して
3. AVR Dragonの接続
4. ﾁｯﾌﾟ上ﾃﾞﾊﾞｯｸﾞ
5. ﾊｰﾄﾞｳｪｱ説明
6. 統合ｿﾌﾄｳｪｱ
7. 特別な考慮
8. 障害対策
9. ﾌｧｰﾑｳｪｱ更新

索引

© HERO 2011.

本ﾍﾙﾌﾟはATMELのAVR Studio 4.19付属の英語版ﾍﾙﾌﾟ(AVRDragon.chm)の翻訳日本語版です。 日本語では不自然となる重複する形容表現は省略されている場合があります。 日本語では難解となる表現は大幅に意訳されている部分もあります。

赤文字の英語部分は、AVR Studioのｳｨﾝﾄﾞｳ内での表記の引用です。 その他の赤文字は重要な部分を表します。

一部のﾘﾝｸは関連CHMﾌｧｲﾙへのﾘﾝｸとなっています。 関連するCHMﾌｧｲﾙが同一ﾌｫﾙﾀﾞ内に存在しないと正常にﾘﾝｸされません。

ｲﾝｽﾄｰﾙ ﾌｫﾙﾀﾞ内のHelpﾌｫﾙﾀﾞ(標準でC:\Program Files\Atmel\AVR Tools\Help)内のAVRDragon.chmを本ﾍﾙﾌﾟに置換することで、AVR Studio内からのﾍﾙﾌﾟも本ﾍﾙﾌﾟに置換されます。


AVR Dragon: 新規情報

序文

新規情報

表1. 本公開での新規事項
ﾌｧｰﾑｳｪｱ版番号 | 主:06.16, 従:06.16
AVR Studio公開版番号 | 4.19
新規支援ﾃﾞﾊﾞｲｽ | ATmega325PA, ATmega3250PA, ATmega3290PA, ATxmega64A3U, ATxmega128A3U, ATxmega192A3U, ATxmega256A3U, ATxmega256A3BU, ATxmega16A4U, ATxmega32A4U


AVR Dragon: ﾌｧｰﾑｳｪｱ履歴

ﾌｧｰﾑｳｪｱ履歴

  • 2010年6月: Sw: 0x060B 0x060B
    • XMEGA A4とより新しいﾃﾞﾊﾞｲｽに対してPDI支援を追加
    • ATmega165A,ATmega169A,ATmega325A,ATmega329A,ATmega645A,ATmega649A,ATmega6450A,ATmega6490Aに対する全ﾃﾞﾊﾞｲｽ支援を追加
  • 2009年12月15日: Sw: 0x060B 0x060B
    • XMEGA A4とより新しいﾃﾞﾊﾞｲｽに対してPDI支援を追加
    • ATmega48A,ATmega88A,ATmega168A,ATmega329PA,ATmega16HVA2,AT32UC3L016,AT32UC3L032に対する全ﾃﾞﾊﾞｲｽ支援を追加
  • 2009年10月15日: Sw: 0x0604 0x0604
    • 32Kﾊﾞｲﾄのﾌﾟﾛｸﾞﾗﾐﾝｸﾞ制限を削除
    • 全AVRﾃﾞﾊﾞｲｽに対するﾃﾞﾊﾞｯｸﾞ支援を追加
    • ATtiny461A,ATmega169PA,ATmega649P,ATmega64HVE,AT32UC3L064,AT32UC3B0512改訂C,AT32UC3C0512,AT32UC3C0512,AT32UC3C2512に対する全ﾃﾞﾊﾞｲｽ支援を追加
  • 2008年10月17日: Sw: 0x0101 0x0200
    • ATmega32HVBに対する全ﾃﾞﾊﾞｲｽ支援を追加
  • 2008年7月27日: Sw: 0x0101 0x0200
    • ATtiny13A,ATmega8A,ATmega16A,ATmega16U4,ATmega32Aに対する全ﾃﾞﾊﾞｲｽ支援を追加
    • ATmega64A,ATmega128Aに対するﾌﾟﾛｸﾞﾗﾐﾝｸﾞ支援を追加
  • 2008年2月20日: Sw: 0x0101 0x0200
    • ATtiny88,ATtiny167,ATmega32C1,ATmega32M1,ATmega32U4に対する全ﾃﾞﾊﾞｲｽ支援を追加
  • 2007年11月21日: Sw: 0x0101 0x0200
    • ATmega1284Pに対するﾌﾟﾛｸﾞﾗﾐﾝｸﾞ支援を追加
    • ATtiny43U,ATtiny48,ATmega32HVBに対する全ﾃﾞﾊﾞｲｽ支援を追加
  • 2007年7月5日: Sw: 0x0101 0x010A
    • ATmega16HVA,ATmega328P,AT90PWM216,AT90PWM316,AT90USB82,AT90USB162に対してﾃﾞﾊﾞｲｽ支援を追加
    • ﾌﾟﾛｼﾞｪｸﾄのﾃﾞﾊﾞｯｸﾞでﾃﾞﾊﾞｯｸﾞWIRE動作許可でのﾌｧｰﾑｳｪｱの問題を修正
  • 2007年2月26日: Sw: 0x0101 0x0109
    • ATmega88PとATmega168Pに対してﾃﾞﾊﾞｲｽ支援を追加
  • 2007年1月4日: Sw: 0x0101 0x0109
    • 追加ﾃﾞﾊﾞｲｽを全AVRﾃﾞﾊﾞｲｽに対して支援(64Kﾊﾞｲﾄまたはそれ以上のﾌﾗｯｼｭのﾃﾞﾊﾞｲｽでのﾃﾞﾊﾞｯｸﾞなし)
    • 高電圧ｲﾝﾀｰﾌｪｰｽでのﾀｲﾐﾝｸﾞの問題を修正。
    • ISP線でのｽｷｭｰを扱うためにより強力なISPﾌﾟﾛｸﾞﾗﾐﾝｸﾞにしました。
  • 2006年9月18日: Sw: 0x0100 0x0103
    • ﾃﾞﾊﾞｯｸﾞWIRE動作で10ﾊﾞｲﾄより多くのﾃﾞｰﾀのEEPROM書き込みでの問題を修正。
    • ISPﾌﾟﾛｸﾞﾗﾐﾝｸﾞ周波数読み書きでの問題を修正。
    • PP/HVSPが最後に使用された場合、それらがﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ｲﾝﾀｰﾌｪｰｽとして自動的に選択されるのを修正。
    • AVR Dragon接続/切断時に問題を引き起こす、USB再列挙(再接続)の問題を修正。
    • 目的電圧が1.8V以下のとき、AVR Dragonは "Could not find target voltage" ではなく、今や実際の電圧を報告します。
  • 2006年8月3日: Sw: 0x0100 0x0102
    • ATmega16, ATmega169, ATmega325P, ATmega3250P, ATmega329P, ATmega3290Pに関して完全に支援。
  • AVR Studio 4.12 SP3 - 2006年6月29日: Sw: 0x0100 0x0102
    • 低速ISPﾌﾟﾛｸﾞﾗﾐﾝｸﾞを発生するﾊﾞｸﾞを修正。
  • AVR Studio 4.12 SP3 - 2006年6月12日: Sw: 0x0100 0x0101
    • ATmega48/88/168, ATmega8, ATmega32, ATmega128, ATtiny13, ATtiny25/45/85, ATtiny2313に関して完全に支援。


AVR Dragon: ﾃﾞﾊﾞｲｽ支援

ﾃﾞﾊﾞｲｽ支援

どのﾃﾞﾊﾞｲｽが現在支援されているのかを見るには支援ﾃﾞﾊﾞｲｽ頁を読んでください。


AVR Dragon: 技術支援

技術支援

技術的な支援を求める前に、最終的に利用可能なAVR Studioやﾂｰﾙのﾌｧｰﾑｳｪｱがｲﾝｽﾄｰﾙされているのを確認してください。 最終版のAVR Studioは www.atmel.com/avrstudio からﾀﾞｳﾝﾛｰﾄﾞでき、これはATMELの全AVRﾂｰﾙに対する最終版ﾌｧｰﾑｳｪｱを含みます。 ﾂｰﾙ接続時、AVR Studioはﾌｧｰﾑｳｪｱの版を調べ、必要なら更新を求めます。

技術的な支援については avr@atmel.com にお問い合わせください。 AVR Dragonに関して技術的な支援を求めるとき、以下の情報を含めてください。

  • AVR StudioのVer番号。 これはAVR StudioのﾒﾆｭｰからHelp⇒Aboutで得られます。
  • ﾊﾟｿｺﾝのﾌﾟﾛｾｯｻ型式と速度
  • ﾊﾟｿｺﾝのｵﾍﾟﾚｰﾃｨﾝｸﾞ ｼｽﾃﾑと版番号
  • どの目的AVRﾃﾞﾊﾞｲｽが使用されているか (完全なﾃﾞﾊﾞｲｽ番号)
  • AVR上のﾋｭｰｽﾞ設定
  • 目的ｸﾛｯｸ周波数
  • ｸﾛｯｸ前置分周器(CLKPR)使用の有無 (この機能を持つAVRに対して)
  • 目的電圧
  • ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ速度
  • 問題点の詳細記述とその再現方法
  • 異常発生時はAVR Studioによって生成された異常または警告情報(ﾒｯｾｰｼﾞ内容)


AVR Dragon: 既知の問題

既知の問題

  • 高位(ｿｰｽ ﾚﾍﾞﾙ)の1行実行(Single step)は64Kﾊﾞｲﾄよりも高いﾌﾗｯｼｭ ﾒﾓﾘのｱﾄﾞﾚｽで信用できないかもしれません。これらの筋書きでは低位(逆ｱｾﾝﾌﾞﾘ ﾚﾍﾞﾙ)が使用されるべきです。
  • A4系とより新しいXMEGAﾃﾞﾊﾞｲｽでのPDIﾌﾟﾛｸﾞﾗﾐﾝｸﾞ/ﾃﾞﾊﾞｯｸﾞだけを支援します。 完全な一覧については「支援ﾃﾞﾊﾞｲｽ」をご覧ください。
  • 3.5V以上で走行し、CKOUTﾋｭｰｽﾞが許可されたPDIP外囲器でのJTAG通信は、AVR DragonからPDIPのAVRへ長い配線の場合に不安定になるかもしれません。
  • ATtiny43Uﾌﾟﾛｸﾞﾗﾐﾝｸﾞでの問題 : 内蔵RC発振器ﾋｭｰｽﾞが最短起動時間で設定される場合、並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞは失敗するかもしれません。
  • ATtiny84ﾌﾟﾛｸﾞﾗﾐﾝｸﾞでの問題 : DWENﾋｭｰｽﾞと何れかの外部ｸﾛｯｸ選択ﾋｭｰｽﾞの両方が同時に許可される場合、ATtiny84で並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞが失敗するかもしれません。 対策は本ﾃﾞﾊﾞｲｽの並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞにSTK500基板を使用することです。
  • ATtiny26ﾌﾟﾛｸﾞﾗﾐﾝｸﾞでの問題 : ATtiny26の並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞはAVR Dragonで不安定です。 対策は本ﾃﾞﾊﾞｲｽの並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞにSTK500基板を使用することです。
  • 目的電圧が存在しない場合にﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ﾀﾞｲｱﾛｸﾞ内でHW Settigsﾀﾌﾞへ移行すると、異常ﾒｯｾｰｼﾞが起動されるでしょう。
  • ISP周波数を設定するために、AVR Dragonは目的対象を検出することが必要です。 「障害対策の指針」をご覧ください。
  • 停止中にﾃﾞﾊﾞｯｸﾞが終了されると、目的対象は(ﾘｾｯﾄ ﾍﾞｸﾀから)動作を継続するのにﾘｾｯﾄが必要です。 走行中(または一時停止中)にﾃﾞﾊﾞｯｸﾞが終了されると、目的対象はﾃﾞﾊﾞｯｸﾞ作業終了時に実行を続けます。
  • ﾃﾞﾊﾞｯｸﾞ中またはﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ﾀﾞｲｱﾛｸﾞが開いている時の目的対象電源の切り替えは支援されません。 これはAVR Dragonを目的対象との接続を喪失させ、作業は改めて始めなければなりません。


AVR Dragon: 導入

第1章 導入

ｼｽﾃﾑ概要

表1-1. 表面 | 表1-2. 裏面

AVR Dragonと共に、ATMELは低価格開発ﾂｰﾙ用の新しい基準を設定します。 AVR DragonはATMELのAVRとAVR32ﾃﾞﾊﾞｲｽ系統に対する全てのﾌﾟﾛｸﾞﾗﾐﾝｸﾞ動作を支援します。 また、殆どのAVRﾃﾞﾊﾞｲｽに対して完全なｴﾐｭﾚｰﾄ支援も含みます。

この種の特徴的なﾂｰﾙに関連した伝統的な価格の部分で、AVR Dragonはあなたのﾌﾟﾛｸﾞﾗﾐﾝｸﾞとｴﾐｭﾚｰﾄの要求を完全に満たすでしょう。 柔軟で安全なﾌｧｰﾑｳｪｱ更新機能は、新規ﾃﾞﾊﾞｲｽを支援するためのAVR Dragonの容易な更新をAVR Studioに許します。

どのﾃﾞﾊﾞｲｽが現在支援されているかを見るには、「支援ﾃﾞﾊﾞｲｽ」頁を読んでください。

(新規ﾃﾞﾊﾞｲｽはAVR Studio更新またはｻｰﾋﾞｽ ﾊﾟｯｸを通して定期的に追加されるでしょう。)

AVR Dragonは外部目的基板と共に使用できます。 けれども基板上の試作領域は配線ｹｰﾌﾞﾙの他にどんな付加的なﾊｰﾄﾞｳｪｱもなしに、簡単なﾌﾟﾛｸﾞﾗﾐﾝｸﾞとﾃﾞﾊﾞｯｸﾞを許します。 この使用法の記述は「基板上試作領域」章をご覧ください。

AVR DragonはUSBｹｰﾌﾞﾙによって給電され、ﾌﾟﾛｸﾞﾗﾐﾝｸﾞまたはﾃﾞﾊﾞｯｸﾞ時に外部目的対象に(VCCｺﾈｸﾀから)300mAまで流せます。 技術的な詳細のより多くの情報については「電気的な制限」章を読んでください。 この目的対象が既に外部電源によって給電されているなら、AVR Dragonは目的対象とAVR Dragon間の全ての信号をﾚﾍﾞﾙ変換して適応します。

注 目的基板が外部電源によって給電される場合、VCCｺﾈｸﾀと外部基板間は接続されるべきではありません。

AVR DragonはAVR Studioによって完全に支援されます。 これは新しいﾃﾞﾊﾞｲｽや規約を支援するための容易な更新をAVR Dragonのﾌｧｰﾑｳｪｱに許します。 AVR Dragonを接続すると、AVR Studioはﾌｧｰﾑｳｪｱを自動的に調べ、更新されたﾌｧｰﾑｳｪｱが利用可能なら、使用者に通知します。


AVR Dragon: ｼｽﾃﾑの必要条件

ｼｽﾃﾑの必要条件

ﾊｰﾄﾞｳｪｱとｿﾌﾄｳｪｱの最低必要条件は次の通りです。
  • Pentium (PentiumⅡ以上推奨)
  • Windows98, WindowsME, Windows2000またはWindowsXP
  • 128Mﾊﾞｲﾄ RAM
  • AVR Studio 4.12とSP3
  • USBﾎﾟｰﾄ、自己給電(500mAが必要)
  • ｿﾌﾄｳｪｱのﾀﾞｳﾝﾛｰﾄﾞ用のｲﾝﾀｰﾈｯﾄ接続

注 Windows95とWindowsNTはUSBを支援しないので、故にAVR Dragonとの使用はできません。


AVR Dragon: 電気的な制限

電気的な制限

表1-1. ｼｽﾃﾑ部
電源電圧必要条件 | 5.0V USB給電
AVR Dragon消費電流 | 150mA
(目的対象への)最大供給電流能力 | 300mA
周辺温度 | 0～70℃

表1-2. 動作
目的対象電圧範囲 1.8～5.5V

表1-3. 入出力ﾋﾟﾝ
ISP/JTAGﾍｯﾀﾞの最大ﾌﾟﾙｱｯﾌﾟ | 1kΩ
ISP/JTAGﾍｯﾀﾞの最大ﾌﾟﾙﾀﾞｳﾝ | 10kΩ
Vccﾍｯﾀﾞの最大供給電流 | 合計最大300mA

注 AVR Dragonは500mAを配給できるUSBﾎﾟｰﾄ(自己給電USBﾊﾌﾞ)が必要です。


AVR Dragon: 支援ﾃﾞﾊﾞｲｽ

支援ﾃﾞﾊﾞｲｽ

表2-1. ﾃﾞﾊﾞｲｽのﾌﾟﾛｸﾞﾗﾐﾝｸﾞとﾃﾞﾊﾞｯｸﾞの支援
ﾃﾞﾊﾞｲｽ | ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ |  |  |  |  | ﾃﾞﾊﾞｯｸﾞ |  |  | 接続ｼｰﾄ | 備考
 | HVPP | HVSP | ISP | JTAG/dW | PDI | JTAG | PDI | dW
ATtiny
ATtiny11 |  | ○ |  |  |  |  |  |  | SCKT3400D1 |
ATtiny12 |  | ○ | ○ |  |  |  |  |  | SCKT3400D1 |
ATtiny13 |  | ○ | ○ |  |  |  |  | ○ | SCKT3400D1 |
ATtiny13A |  | ○ | ○ |  |  |  |  | ○ | SCKT3400D1 |
ATtiny15 |  | ○ | ○ |  |  |  |  |  | SCKT3600A1 |
ATtiny2313 | ○ |  | ○ |  |  |  |  | ○ | SCKT3300D3 |
ATtiny2313A | ○ |  | ○ |  |  |  |  | ○ | SCKT3300D3 |
ATtiny24 |  | ○ | ○ |  |  |  |  | ○ | SCKT244484 |
ATtiny24A |  | ○ | ○ |  |  |  |  | ○ | SCKT244484 |
ATtiny25 |  | ○ | ○ |  |  |  |  | ○ | SCKT3400D1 |
ATtiny26 | ○ |  | ○ |  |  |  |  |  | SCKT3700A1 |
ATtiny261 | ○ |  | ○ |  |  |  |  | ○ | SCKT3700A1 |
ATtiny261A | ○ |  | ○ |  |  |  |  | ○ | SCKT3700A1 |
ATtiny28 | ○ |  |  |  |  |  |  |  | SCKT3500D- |
ATtiny43U | ○ |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
ATtiny4313 | ○ |  | ○ |  |  |  |  | ○ | SCKT3300D3 |
ATtiny44 |  | ○ | ○ |  |  |  |  | ○ | SCKT244484 |
ATtiny44A |  | ○ | ○ |  |  |  |  | ○ | SCKT244484 |
ATtiny45 |  | ○ | ○ |  |  |  |  | ○ | SCKT3400D1 |
ATtiny461 | ○ |  | ○ |  |  |  |  | ○ | SCKT3700A1 |
ATtiny461A | ○ |  | ○ |  |  |  |  | ○ | SCKT3700A1 |
ATtiny48 | ○ |  | ○ |  |  |  |  | ○ | SCKT3200A2 |
ATtiny84 |  | ○ | ○ |  |  |  |  | ○ | SCKT244484 |
ATtiny85 |  | ○ | ○ |  |  |  |  | ○ | SCKT3400D1 |
ATtiny861 | ○ |  | ○ |  |  |  |  | ○ | SCKT3700A1 |
ATtiny861A | ○ |  | ○ |  |  |  |  | ○ | SCKT3700A1 |
ATtiny87 | ○ |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
ATtiny88 | ○ |  | ○ |  |  |  |  | ○ | SCKT3200A2 |
ATtiny167 | ○ |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
ATmega
ATmega48 | ○ |  | ○ |  |  |  |  | ○ | SCKT3200A2 |
ATmega48A | ○ |  | ○ |  |  |  |  | ○ | SCKT3200A2 |
ATmega48P | ○ |  | ○ |  |  |  |  | ○ | SCKT3200A2 |
ATmega48PA | ○ |  | ○ |  |  |  |  | ○ | SCKT3200A2 |
ATmega8 | ○ |  | ○ |  |  |  |  |  | SCKT3200A2 |
ATmega8A | ○ |  | ○ |  |  |  |  |  | SCKT3200A2 |
ATmega8HVA |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
ATmega8U2 |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
ATmega8515 | ○ |  | ○ |  |  |  |  |  | SCKT3000D3 |
ATmega8535 | ○ |  | ○ |  |  |  |  |  | SCKT3100A3 |
ATmega88 | ○ |  | ○ |  |  |  |  | ○ | SCKT3200A2 |
ATmega88P | ○ |  | ○ |  |  |  |  | ○ | SCKT3200A2 |
ATmega16 | ○ |  | ○ | ○ |  | ○ |  |  | SCKT3100A3 |
ATmega16A | ○ |  | ○ | ○ |  | ○ |  |  | SCKT3100A3 |
ATmega16HVA |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
ATmega16HVA2 |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
ATmega16HVB |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
ATmega16M1 |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
ATmega16U2 |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
ATmega16U4 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega162 | ○ |  | ○ | ○ |  | ○ |  |  | SCKT3000D3 |
ATmega164A | ○ |  | ○ | ○ |  | ○ |  |  | SCKT3100A3 |
ATmega164P | ○ |  | ○ | ○ |  | ○ |  |  | SCKT3100A3 |
ATmega164PA | ○ |  | ○ | ○ |  | ○ |  |  | SCKT3100A3 |
ATmega165 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega165A |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega165P |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega168 | ○ |  | ○ |  |  |  |  | ○ | SCKT3200A2 |
ATmega168P | ○ |  | ○ |  |  |  |  | ○ | SCKT3200A2 |
ATmega169 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega169A |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega169P |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega169PA |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega32 | ○ |  | ○ | ○ |  | ○ |  |  | SCKT3100A3 |
ATmega32A | ○ |  | ○ | ○ |  | ○ |  |  | SCKT3100A3 |
ATmega32C1 |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
ATmega32HVB |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
ATmega32M1 |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
ATmega32U2 |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
ATmega32U4 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega324A | ○ |  | ○ | ○ |  | ○ |  |  | SCKT3100A3 |
ATmega324P | ○ |  | ○ | ○ |  | ○ |  |  | SCKT3100A3 |
ATmega324PA | ○ |  | ○ | ○ |  | ○ |  |  | SCKT3100A3 |
ATmega325 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega325A |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega325P |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega325PA |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega3250 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega3250P |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega3250PA |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega328 | ○ |  | ○ |  |  |  |  | ○ | SCKT3200A2 |
ATmega328P | ○ |  | ○ |  |  |  |  | ○ | SCKT3200A2 |
ATmega329 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega329A |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega329P |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega329PA |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega3290 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega3290P |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega3290PA |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega406 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega64 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega64A |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega64C1 |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
ATmega64HVE |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
ATmega64M1 |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
ATmega640 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega644 | ○ |  | ○ | ○ |  | ○ |  |  | SCKT3100A3 |
ATmega644A | ○ |  | ○ | ○ |  | ○ |  |  | SCKT3100A3 |
ATmega644P | ○ |  | ○ | ○ |  | ○ |  |  | SCKT3100A3 |
ATmega644PA | ○ |  | ○ | ○ |  | ○ |  |  | SCKT3100A3 |
ATmega645 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega645A |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega6450 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega6450A |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega649 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega649A |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega649P |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega6490 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega6490A |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega128 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega128A |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega128RFA1 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega1280 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega1281 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega1284 |  |  | ○ | ○ |  | ○ |  |  | SCKT3100A3 |
ATmega1284P |  |  | ○ | ○ |  | ○ |  |  | SCKT3100A3 |
ATmega2560 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATmega2561 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
その他mega系
AT90CAN32 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
AT90CAN64 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
AT90CAN128 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
AT90PWM81 |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
AT90PWM1 |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
AT90PWM2 |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
AT90PWM2B |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
AT90PWM216 |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
AT90PWM3 |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
AT90PWM3B |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
AT90PWM316 |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
AT90USB82 |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
AT90USB162 |  |  | ○ |  |  |  |  | ○ | 基板外目的対象 |
AT90USB646 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
AT90USB647 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
AT90USB1286 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
AT90USB1287 |  |  | ○ | ○ |  | ○ |  |  | 基板外目的対象 |
ATxmega
ATxmega64A1 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
ATxmega128A1 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
ATxmega64A3 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
ATxmega128A3 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
ATxmega192A3 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
ATxmega256A3 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
ATxmega256A3B |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
ATxmega64A3U |  |  |  | ○ | ○ | ○ | ○ |  | 基板外目的対象 |
ATxmega128A3U |  |  |  | ○ | ○ | ○ | ○ |  | 基板外目的対象 |
ATxmega192A3U |  |  |  | ○ | ○ | ○ | ○ |  | 基板外目的対象 |
ATxmega256A3U |  |  |  | ○ | ○ | ○ | ○ |  | 基板外目的対象 |
ATxmega256A3BU |  |  |  | ○ | ○ | ○ | ○ |  | 基板外目的対象 |
ATxmega16A4 |  |  |  |  | ○ |  | ○ |  | 基板外目的対象 |
ATxmega32A4 |  |  |  |  | ○ |  | ○ |  | 基板外目的対象 |
ATxmega16A4U |  |  |  |  | ○ |  | ○ |  | 基板外目的対象 |
ATxmega32A4U |  |  |  |  | ○ |  | ○ |  | 基板外目的対象 |
AVR32
AT32UC3A0128 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3A0256 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3A0512 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3A0512ES |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3A1128 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3A1256 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3A1512 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3A3128 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3A3128S |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3A3256 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3A3256S |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3A364 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3A364S |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3B0128 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3B0256 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3B0256ES |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3B0512改訂C |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3B064 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3B1128 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3B1256 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3B1512 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3B164 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3C0512改訂C |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3C1512改訂C |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3C2512改訂C |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3L016 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3L032 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3L064改訂B |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |
AT32UC3L0256 |  |  |  | ○ |  | ○ |  |  | 基板外目的対象 |


AVR Dragon: 支援規約

支援規約

現在、次の規約が支援されています。

ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ｲﾝﾀｰﾌｪｰｽ

  • 実装書き込み ( ISP )
  • 高電圧直列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ( HVSP )
  • 並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ( PP )
  • JTAGﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ( JTAG Prog )
  • 選ばれたﾃﾞﾊﾞｲｽでのPDIﾌﾟﾛｸﾞﾗﾐﾝｸﾞ (PDI)

ﾃﾞﾊﾞｯｸﾞ用ｲﾝﾀｰﾌｪｰｽ

  • JTAG ( JTAG )
  • ﾃﾞﾊﾞｯｸﾞWIRE ( dW )
  • 選ばれたﾃﾞﾊﾞｲｽでのPDI (PDI)


AVR Dragon: 開始に際して

第2章 開始に際して

AVR Dragonをｺﾝﾋﾟｭｰﾀまたは目的対象へ接続するのに先立って本項を読んでください。

重要! AVR Dragonをﾊﾟｿｺﾝに接続する前にAVR StudioとUSBﾄﾞﾗｲﾊﾞをｲﾝｽﾄｰﾙしてください。

AVR Dragonの使用を始めるにはこれらの簡単な手順に従ってください。

  1. http://www.atmel.com/avrdragon からAVR Studio 4.12 SP3またはそれ以降をﾀﾞｳﾝﾛｰﾄﾞしてください。
  2. AVR StudioとUSBﾄﾞﾗｲﾊﾞをｲﾝｽﾄｰﾙしてください。
  3. AVR Dragonをｺﾝﾋﾟｭｰﾀに接続し、ｺﾝﾋﾟｭｰﾀ上で新しいﾊｰﾄﾞｳｪｱ(AVR Dragon)を自動ｲﾝｽﾄｰﾙしてください。
  4. AVR StudioとAVR Dragonﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ﾀﾞｲｱﾛｸﾞを開始してください。
  5. AVR Dragonを目的対象へ接続してください。

AVR Dragonの開封

この箱は以下を含みます。
  • AVR Dragon ﾂｰﾙ
  • ｿﾌﾄｳｪｱへのｲﾝﾀｰﾈｯﾄ ﾘﾝｸ ( http://www.atmel.com/avrdragon )

AVR DragonではCDが同梱されません。 ｿﾌﾄｳｪｱを得るための方法はｲﾝﾀｰﾈｯﾄからの直接ﾀﾞｳﾝﾛｰﾄﾞだけです。

また以下が必要です(これらは含まれません)。

  • 空きUSBｺﾈｸﾀを持つﾊﾟｿｺﾝ、または500mAを配給できるUSBﾊﾌﾞ
  • USBｹｰﾌﾞﾙ
  • AVR Studio 4.12とSP3、またはそれ以降 ( ﾘﾝｸ: http://www.atmel.com/avrdragon )
  • 6/10ﾋﾟﾝ ﾍｯﾀﾞ ｺﾈｸﾀ (またはAVR Dragonを目的基板に接続するための同様のｹｰﾌﾞﾙ)


AVR Dragon: 心得

心得

  • 目的対象への電源投入または接続に先立って、常に先行してAVR Dragonに電源投入してください。
  • AVR DragonはISPﾍｯﾀﾞの2ﾋﾟﾝまたはJTAGﾍｯﾀﾞの4ﾋﾟﾝでの目的電圧検出を必要とします。
    • これは高電圧ｲﾝﾀｰﾌｪｰｽ使用時にも適用します。
  • 高電圧ｲﾝﾀｰﾌｪｰｽは5Vに設定されます。 これの基板外ｲﾝﾀｰﾌｪｽを使用する前に目的基板の5Vでの走行を確認してください。
  • VCCﾍｯﾀﾞは5Vに設定され、最大300mA流せます。
  • AVR DragonがSTK500上の目的対象をﾌﾟﾛｸﾞﾗﾐﾝｸﾞ/ﾃﾞﾊﾞｯｸﾞに使用される場合、STK500上のRESETｼﾞｬﾝﾊﾟは取り去られなければなりません。


AVR Dragon: ｿﾌﾄｳｪｱとUSBの設定

ｿﾌﾄｳｪｱとUSBの設定

ｿﾌﾄｳｪｱとUSBの設定

AVR Dragonを使用するにはUSBﾄﾞﾗｲﾊﾞのｲﾝｽﾄｰﾙが必要とされます。 USB設定を走行する前にAVR Dragonをｺﾝﾋﾟｭｰﾀに接続しないでください。 USBﾄﾞﾗｲﾊﾞのｲﾝｽﾄｰﾙはAVR Studioのｲﾝｽﾄｰﾙ中に行われます。

注 AVR DragonはAVR Studio 4.12とSP3、またはそれ以降を必要とします。 AVR Studioの最終版は www.atmel.com/products/AVR/ で得られます。

AVR Studioのｲﾝｽﾄｰﾙを始めてください。 このｲﾝｽﾄｰﾙ間に下図のﾀﾞｲｱﾛｸﾞ ﾎﾞｯｸｽが使用者に対して表示されるでしょう。

USBﾄﾞﾗｲﾊﾞをｲﾝｽﾄｰﾙするには、Install/Upgrade USB Driverﾁｪｯｸ ﾎﾞｯｸｽをﾁｪｯｸしてください。 USBﾄﾞﾗｲﾊﾞは自動的にｲﾝｽﾄｰﾙされるでしょう。

ｺﾝﾋﾟｭｰﾀ上の新しいﾊｰﾄﾞｳｪｱのｲﾝｽﾄｰﾙ

AVR StudioとUSBﾄﾞﾗｲﾊﾞのｲﾝｽﾄｰﾙが終わったなら、USBｹｰﾌﾞﾙをﾊﾟｿｺﾝとAVR Dragonの両方に取り付けてください。 (AVR DragonはUSBから給電されます)。 AVR Dragonがｺﾝﾋﾟｭｰﾀに初めて接続されるなら、以下のﾎﾞｯｸｽが現れるでしょう。

WindowsXPが走行している場合、Nextを2度ｸﾘｯｸする必要があります。 ｲﾝｽﾄｰﾙ処理がそれ自身によって完了するまで待ってください。 これはｺﾝﾋﾟｭｰﾀとOSに依存して数秒から数分までかかるかもしれません。

USBﾄﾞﾗｲﾊﾞが正しくｲﾝｽﾄｰﾙされ、AVR Dragonがﾊﾟｿｺﾝに接続されたなら、USBｺﾈｸﾀの傍でｹｰｽに入った内側の緑LEDが点灯されるでしょう。

いくつかの理由のためにAVR StudioがUSB設定後にAVR Dragonを検出できない場合、このﾄﾞﾗｲﾊﾞを正しく読み込ませるためにｺﾝﾋﾟｭｰﾀの再始動を試みてください。

AVR Studioがｲﾝｽﾄｰﾙされた後でのUSBﾄﾞﾗｲﾊﾞのｲﾝｽﾄｰﾙ

USBﾄﾞﾗｲﾊﾞはAVR Studioがｲﾝｽﾄｰﾙされてしまった後でも以下のこれらの手順によってｲﾝｽﾄｰﾙできます。
  1. ﾊﾟｿｺﾝ上で"ｺﾝﾄﾛｰﾙ ﾊﾟﾈﾙ"を開いてください。 (Windows95とWindowsNTはUSBを支援しません。)
  2. "ﾌﾟﾛｸﾞﾗﾑの追加と削除"を選択してください。
  3. ﾌﾟﾛｸﾞﾗﾑの一覧内で"AVRStudio4"を選択してください。
  4. "変更"ﾎﾞﾀﾝ上をｸﾘｯｸしてください。
  5. 編集"Modify"を選択してください。
  6. "Install/upgrade USB Driver"を選択してください。

USBﾄﾞﾗｲﾊﾞは今や正しくﾊﾟｿｺﾝ上にｲﾝｽﾄｰﾙされました。

注 AVR Dragonは500mAを配給できるUSBﾎﾟｰﾄ(自己給電USBﾊﾌﾞ)が必要です。


AVR Dragon: AVR Dragon接続

AVR Dragon接続

ﾌﾟﾛｸﾞﾗﾐﾝｸﾞとﾃﾞﾊﾞｯｸﾞに関する目的対象への接続の情報については「AVR Dragonの接続」項をご覧ください。


AVR Dragon: AVR Dragonの接続

第3章 AVR Dragonの接続

ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ

実装書き込み (ISP)

実装書き込みは外部の目的基板上に半田付けされたﾃﾞﾊﾞｲｽをﾌﾟﾛｸﾞﾗﾐﾝｸﾞするのに上手く適合されます。 本章は外部目的対象をISPﾌﾟﾛｸﾞﾗﾐﾝｸﾞするためのAVR Dragonの接続方法を説明します。 ISP線はAVR Dragonを目的基板電圧にﾚﾍﾞﾙを自動的に移行するﾚﾍﾞﾙ変換が装備されます。

ISPﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ｲﾝﾀｰﾌｪｰｽへの容易なｱｸｾｽを許すために、目的基板上に2.54mm(100mil)ﾋﾟｯﾁの6ﾋﾟﾝ ﾍｯﾀﾞ ｺﾈｸﾀが配置されることが推奨されます。 次のﾋﾟﾝ配列が使用されるべきです。

図3-1. 2.54mm(100mil)ﾋﾟｯﾁ 6ﾋﾟﾝ ﾍｯﾀﾞ ｺﾈｸﾀ

注 AVR Dragonを目的対象へ接続するとき、MISOを目的ﾃﾞﾊﾞｲｽのMISOへ、MOSIをMOSIへ、以下同様に接続してください。

注 AVR Dragonはﾚﾍﾞﾙ変換器を設定するためにISPﾍｯﾀﾞの2ﾋﾟﾝで目的電圧を検出しなければなりません。 基板上では、この電圧がVCCﾍｯﾀﾞの2,4,6ﾋﾟﾝ(5V)からISPﾍｯﾀﾞの2ﾋﾟﾝ(VTG)へ供給されなければなりません。 基板外目的対象使用時、VCCﾍｯﾀﾞとISPﾍｯﾀﾞの2ﾋﾟﾝ間を未接続にすべきです。

これらの図で示されるようにAVR Dragonから外部の目的対象へ6芯ｹｰﾌﾞﾙを接続してください。

図3-2. AVR Dragon ISPｺﾈｸﾀ接続

図3-3. 目的対象基板ISPｺﾈｸﾀ接続

ﾃﾞﾊﾞｯｸﾞWIRE内蔵ﾃﾞﾊﾞｯｸﾞ機能もこのISPﾍｯﾀﾞを通してｱｸｾｽされます。

目的ﾃﾞﾊﾞｲｽをﾌﾟﾛｸﾞﾗﾐﾝｸﾞするための"ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ﾀﾞｲｱﾛｸﾞ"の使用については、AVR Studio使用者の手引きをご覧ください。

JTAGﾌﾟﾛｸﾞﾗﾐﾝｸﾞ説明

JTAGｲﾝﾀｰﾌｪｰｽを持つAVRﾃﾞﾊﾞｲｽはこのｲﾝﾀｰﾌｪｰｽを通したﾌﾟﾛｸﾞﾗﾐﾝｸﾞも支援します。 JTAGﾌﾟﾛｸﾞﾗﾐﾝｸﾞ用の接続はJTAGﾃﾞﾊﾞｯｸﾞ ｲﾝﾀｰﾌｪｰｽと同じです。 外部の目的基板へのAVR Dragon接続法の情報については「JTAGｲﾝﾀｰﾌｪｰｽを通した目的対象への接続」章をご覧ください。

AVR Dragonの試作領域上に配置したﾃﾞﾊﾞｲｽをJTAGﾌﾟﾛｸﾞﾗﾐﾝｸﾞすることも可能です。 各種AVRﾃﾞﾊﾞｲｽの接続方法の情報については各々の「ﾃﾞﾊﾞｲｽ接続ｼｰﾄ」をご覧ください。

図3-4. JTAGﾍｯﾀﾞ

目的ﾃﾞﾊﾞｲｽをﾌﾟﾛｸﾞﾗﾐﾝｸﾞするための"ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ﾀﾞｲｱﾛｸﾞ"の使用についてはAVR Studio使用者の手引きをご覧ください。

PDIﾌﾟﾛｸﾞﾗﾐﾝｸﾞ説明

PDIｲﾝﾀｰﾌｪｰｽを持つAVRﾃﾞﾊﾞｲｽもこのｲﾝﾀｰﾌｪｰｽを通してﾌﾟﾛｸﾞﾗﾐﾝｸﾞを支援します(例外をご覧ください)。 PDIﾌﾟﾛｸﾞﾗﾐﾝｸﾞ用の接続はPDIﾃﾞﾊﾞｯｸﾞ ｲﾝﾀｰﾌｪｰｽと同じです。 AVR Dragonを外部目的対象基板に接続する方法の情報については「PDIｲﾝﾀｰﾌｪｰｽを通した目的対象への接続」項をご覧ください。

図3-5. PDIﾍｯﾀﾞ

目的ﾃﾞﾊﾞｲｽをﾌﾟﾛｸﾞﾗﾐﾝｸﾞするための"ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ﾀﾞｲｱﾛｸﾞ"の使用についてはAVR Studio使用者の手引きをご覧ください。

並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ説明

ﾋﾟﾝ数の多いAVRﾃﾞﾊﾞｲｽは完全な並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ｲﾝﾀｰﾌｪｰｽを支援します。 このｲﾝﾀｰﾌｪｰｽは高速ﾌﾟﾛｸﾞﾗﾐﾝｸﾞを提供し、AVRﾃﾞﾊﾞｲｽ内の全てのﾋｭｰｽﾞとﾛｯｸ ﾋﾞｯﾄのﾌﾟﾛｸﾞﾗﾐﾝｸﾞも支援します。

重要! 外部の目的対象上のAVRﾃﾞﾊﾞｲｽをﾌﾟﾛｸﾞﾗﾐﾝｸﾞするためにPP動作を使用する場合、極端な注意が祓われるべきです。 PP線はﾚﾍﾞﾙ変換器を持たず、故に目的対象自身の電源を使用せずに、AVR DragonのVCCﾍｯﾀﾞによって目的基板が給電されることが重要です。 加えてAVR DragonはRESETﾋﾟﾝに12Vを印加し、故に目的基板がこの線上で12Vを扱うように設計されることが重要です。
注 目的電圧、換言するとVCCﾍｯﾀﾞからの5VがISPﾍｯﾀﾞの2ﾋﾟﾝまたはJTAGﾍｯﾀﾞの4ﾋﾟﾝのどちらかに印加されなければならないことに注意してください。 これはAVR Dragonが目的電圧を読まなければならないためです。

目的基板またはAVR Dragon、またはその両方の損傷を避けるため、AVR Dragon上のAVR試作領域上の28/40ﾋﾟﾝDIPｿｹｯﾄに配置されたﾃﾞﾊﾞｲｽ上にだけPP動作を使用することが推奨されます。

図3-6. 試作領域

HV_PROGﾍｯﾀﾞ ﾋﾟﾝ配置は以下で一覧されます。 これは全AVRﾃﾞﾊﾞｲｽについての標準ﾋﾟﾝ配置です。 然しながら、HV_PROGﾍｯﾀﾞのﾋﾟﾝ配置はいくつかのﾃﾞﾊﾞｲｽに関して僅かに異なり、これらの例外は本頁内の下に続いて一覧されます。

図3-7. 標準ﾋﾟﾝ配置

ATtiny26/261/261A/461/461A/861/861Aに対するHV_PROGﾍｯﾀﾞは以下のﾋﾟﾝ配置を持ちます。

図3-8. ATtiny26/261/261A/461/461A/861/861A用ﾋﾟﾝ配置

ATtiny2313/2313A/4313に対するHV_PROGﾍｯﾀﾞは以下のﾋﾟﾝ配置を持ちます。

図3-9. ATtiny2313/2313A/4313用ﾋﾟﾝ配置

PPﾌﾟﾛｸﾞﾗﾐﾝｸﾞ用のAVR Dragon接続法の情報については各々の「ﾃﾞﾊﾞｲｽ接続ｼｰﾄ」章をご覧ください。

目的ﾃﾞﾊﾞｲｽをﾌﾟﾛｸﾞﾗﾐﾝｸﾞするための"ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ﾀﾞｲｱﾛｸﾞ"の使用についてはAVR Studio使用者の手引きをご覧ください。

高電圧直列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ説明

ﾋﾟﾝ数の少ないAVRﾃﾞﾊﾞｲｽは完全な並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ｲﾝﾀｰﾌｪｰｽを支援するための充分な入出力ﾋﾟﾝを持ちません。 これらのﾃﾞﾊﾞｲｽは並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ｲﾝﾀｰﾌｪｰｽの直列版であるHVSPﾌﾟﾛｸﾞﾗﾐﾝｸﾞを代わりに使用します。

重要! 外部の目的対象上のAVRﾃﾞﾊﾞｲｽをﾌﾟﾛｸﾞﾗﾐﾝｸﾞするためにHVSP動作を使用する場合、極端な注意が祓われるべきです。 HVSP線はﾚﾍﾞﾙ変換器を持たず、故に別の電源を使用せずに、AVR DragonのVCCﾍｯﾀﾞによって目的基板が給電されることが重要です。 加えてAVR DragonはRESETﾋﾟﾝに12Vを印加し、故に目的基板がこの線上で12Vを扱うように設計されることが重要です。
注 目的電圧、換言するとVCCﾍｯﾀﾞからの5VがISPﾍｯﾀﾞの2ﾋﾟﾝまたはJTAGﾍｯﾀﾞの4ﾋﾟﾝのどちらかに印加されなければならないことに注意してください。 これはAVR Dragonが目的電圧を読まなければならないためです。

目的基板またはAVR Dragon、またはその両方の損傷を避けるため、AVR Dragon上のAVR試作領域上の28/40ﾋﾟﾝDIPｿｹｯﾄに配置されたﾃﾞﾊﾞｲｽ上にだけHVSP動作を使用することが推奨されます。

図3-10. 試作領域

高電圧直列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ(HVSP)ｲﾝﾀｰﾌｪｰｽはHV_PROGﾍｯﾀﾞで得られます。 下図はATtiny24/24A/44/44A/84/84Aを除く全ﾃﾞﾊﾞｲｽに対するHVSP使用時のHV_PROGﾍｯﾀﾞ ﾋﾟﾝ配置を示します。

図3-11. 標準ﾋﾟﾝ配置

ATtiny24/24A/44/44A/84/84Aはﾌﾟﾛｸﾞﾗﾐﾝｸﾞ動作移行用に独立したﾋﾟﾝを使用します。 これらﾃﾞﾊﾞｲｽ使用時のHV_PROGﾍｯﾀﾞ ﾋﾟﾝ配置は以下をご覧ください。

図3-12. ATtiny24/24A/44/44A/84/84A用ﾋﾟﾝ配置

支援される各種ﾃﾞﾊﾞｲｽに対するHVSPﾌﾟﾛｸﾞﾗﾐﾝｸﾞ用のAVR Dragon接続法の情報については各々の「ﾃﾞﾊﾞｲｽ接続ｼｰﾄ」をご覧ください。

目的ﾃﾞﾊﾞｲｽをﾌﾟﾛｸﾞﾗﾐﾝｸﾞするための"ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ﾀﾞｲｱﾛｸﾞ"の使用についてはAVR Studio使用者の手引きをご覧ください。

ｺﾏﾝﾄﾞ行ｿﾌﾄｳｪｱ

ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ｲﾝﾀｰﾌｪｰｽのDOSｺﾏﾝﾄﾞ行はSTKｽﾀｰﾀ ｷｯﾄと同じです。 これは"AVRDragon.exe"と名付けられ、自動ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ用の簡単なﾊﾞｯﾁ ﾌｧｲﾙを許します。 本ﾌﾟﾛｸﾞﾗﾑは(既定ｲﾝｽﾄｰﾙで)ﾃﾞｨｽｸ上の [ｲﾝｽﾄｰﾙ時のﾊﾟｽ]\Program Files\Atmel\AVR Tools\AVRDragon\ に配置されます。

"avrdragon -h"入力はAVR Dragonによって現在支援される全ての命令、任意選択、ﾃﾞﾊﾞｲｽを表示します。

命令
-h, -?
本ﾍﾙﾌﾟ表示
-he
終了符号表示
-e
ﾁｯﾌﾟ消去
-f<fusebytes>
上位/下位ﾋｭｰｽﾞ ﾊﾞｲﾄ書き込み。 fusebytesのLSBが下位ﾋｭｰｽﾞ ﾊﾞｲﾄに書かれ、MSBが上位ﾋｭｰｽﾞ ﾊﾞｲﾄに書かれます。
-j<ID>
JTAG識別子(ID)読み出し。 任意選択のID指定時、IDが異なる場合、ﾌﾟﾛｸﾞﾗﾑは終了します。
-l<lockbyte>
ﾛｯｸ ﾊﾞｲﾄを指定値に設定。
-p[f|e|b]
ﾌﾗｯｼｭ(-pf), EEPROM(-pe)または両方(-pb)のﾒﾓﾘをﾌﾟﾛｸﾞﾗﾐﾝｸﾞ(書き込み)。 -if(ﾌﾗｯｼｭ)や-ie(EEPROM)任意選択での入力ﾌｧｲﾙ指定が必要です。
-q
ﾋｭｰｽﾞ ﾊﾞｲﾄ読み出し。選択ﾃﾞﾊﾞｲｽが拡張ﾋｭｰｽﾞを持つ場合、それも読みます。
-r[f|e|b]
ﾌﾗｯｼｭ(-rf), EEPROM(-re)または両方(-rb)のﾒﾓﾘを読み出します。 -of(ﾌﾗｯｼｭ)や-oe(EEPROM)任意選択での出力ﾌｧｲﾙ指定が必要です。
-s
識票ﾊﾞｲﾄ読み出し。
-v[f|e|b]
ﾌﾗｯｼｭ(-vf), EEPROM(-ve)または両方(vb)のﾒﾓﾘの照合。 -if(ﾌﾗｯｼｭ)や-ie(EEPROM)任意選択での入力ﾌｧｲﾙ指定が必要です。
-y
ﾛｯｸ ﾊﾞｲﾄ読み出し。
-E<ext.fuse>
拡張ﾋｭｰｽﾞ ﾊﾞｲﾄ書き込み。
-F<fusebytes>
上位/下位ﾋｭｰｽﾞ ﾊﾞｲﾄ照合。 fusebytesのLSBは下位ﾋｭｰｽﾞ ﾊﾞｲﾄと、MSBは上位ﾋｭｰｽﾞ ﾊﾞｲﾄと比較されます。
-L<lockbyte>
ﾛｯｸ ﾊﾞｲﾄ照合。
-G<ext.fuse>
与えられた値に対して拡張ﾋｭｰｽﾞ ﾊﾞｲﾄ照合。
-O<address>
発振校正ﾊﾞｲﾄ読み出し。 Addressはﾃﾞﾊﾞｲｽのﾃﾞｰﾀｼｰﾄで指定されるﾊﾞｲﾄ位置です。
-S[f|e]<address>
-Oまたは-Zで読まれた発振校正ﾊﾞｲﾄを与えられたﾌﾗｯｼｭ(-Sf)またはEEPROM(-Se)の位置(address)に書きます。
-W
ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽ禁止し、ISP動作を許可します。 ﾃﾞﾊﾞｯｸﾞWIREﾃﾞﾊﾞｲｽに対してだけ利用可能です。
-Y
発振器校正手順を実行。 より多くの情報についてはAVR053応用記述をご覧ください。
-Z<address>
ﾁｯﾌﾟ消去に先立ってEEPROM内のaddressから値を取得。 この値は-S[f|e]命令で再びﾌﾗｯｼｭまたはEEPROMに書けます。
任意選択
-ae<start>,<end>
EEPROMﾒﾓﾘの読む範囲のｱﾄﾞﾚｽ指定。 既定は全ﾒﾓﾘです。
-af<start>,<end>
ﾌﾗｯｼｭ ﾒﾓﾘの読む範囲のｱﾄﾞﾚｽ指定。 既定は全ﾒﾓﾘです。
-d<device>
[必須] ﾃﾞﾊﾞｲｽ型式指定。
-ie<file>
EEPROMﾒﾓﾘ ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ用の入力ﾌｧｲﾙ指定。
-if<file>
ﾌﾗｯｼｭ ﾒﾓﾘ ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ用の入力ﾌｧｲﾙ指定。
-m[i|j|p]
ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ動作選択: ISP(-mi), 並列/高電圧(-mp)またはJTAG(-mj)/(既定)
-oe<file>
EEPROMﾒﾓﾘ読み出し用出力ﾌｧｲﾙ指定。
-of<file>
ﾌﾗｯｼｭ ﾒﾓﾘ読み出し用出力ﾌｧｲﾙ指定。
-z
進捗表示なし。 ﾌｧｲﾙへの出力(ﾘﾀﾞｲﾚｸﾄ)時に有用。
-D<devsbefore,devsafter,bitsbefore,bitsafter>
ﾃﾞｨｰｼﾞｰ ﾁｪｰﾝ設定。 JTAG動作でのみ利用可能。
-I<speed>
ISP周波数(Hz)指定。 ISP動作でだけ利用可能。
-J<speed>
ﾃﾞﾊﾞｲｽ速度(Hz)指定。 JTAG動作に対してのみ利用可能。
-R
ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ中に外部ﾘｾｯﾄ印加。 JTAG動作でだけ利用可能。

使用例: avrdragon.exe -dATmega128 -e -pf -if -mj c:\tmp\test.hex


AVR Dragon: ﾃﾞﾊﾞｯｸﾞ

ﾃﾞﾊﾞｯｸﾞ

JTAGｲﾝﾀｰﾌｪｰｽを通した目的対象への接続

AVR Dragonを目的基板へ接続するには、最低6本の線が必要とされます。 これらの信号はTCK, TDO, TDI, TMS, VTref, GNDです。

任意の線はnSRSTです。 nTRST信号は使用されず、他の装置との互換用に予約されています。

nSRSTは目的のRESET線の制御と監視に使用されます。 とは言え、これは正しいｴﾐｭﾚｰﾄのために必須ではありません。 しかし、応用ｺｰﾄﾞがMCUCSR内のJTDﾋﾞｯﾄをｾｯﾄ(1)すると、JTAGｲﾝﾀｰﾌｪｰｽは禁止されるでしょう。 その目的AVRを再書き込みするためのAVR Dragonに関して、RESETﾋﾟﾝの制御を持つ必要があるでしょう。

下図は正しい動作を保証するために目的AVRへJTAG線がどう接続されるかを示します。 線上での衝突を避けるために、JTAG線と外部回路間に直列抵抗器を配置することが推奨されます。 抵抗値は外部回路とAVRがそれらの最大定格を越えないように選ばれるべきです(換言すると、吐き出しまたは吸い込みの多量の電流)。

目的基板へのAVR Dragon接続

図3-13. ｺﾈｸﾀ接続

図3-14. ﾋﾟﾝ配置

JTAGﾁｪｰﾝ内に配置された多くのﾃﾞﾊﾞｲｽへのAVR Dragon接続

AVR DragonはJTAGﾁｪｰﾝ内に配置されたﾃﾞﾊﾞｲｽのｴﾐｭﾚｰﾄを支援します。 JTAG走査ﾁｪｰﾝ内にN個のﾃﾞﾊﾞｲｽを接続する場合、全てのﾃﾞﾊﾞｲｽはTMSとTCKを並列に接続すべきです。 最初のﾃﾞﾊﾞｲｽはそれのTDIがｴﾐｭﾚｰﾀへ接続され、一方TDOは次のﾃﾞﾊﾞｲｽのTDIへと、ﾃﾞﾊﾞｲｽNまで接続されるべきです。 最後のﾃﾞﾊﾞｲｽはそれのTDOがｴﾐｭﾚｰﾀへ接続されるべきです。

STK500へのAVR Dragon接続

STK500はJTAGｲﾝﾀｰﾌｪｰｽ専用のｺﾈｸﾀを持ちません。 AVR DragonをSTK500基板に接続するには、ﾊﾞﾗ線ｹｰﾌﾞﾙを使用してJTAGﾌﾟﾛｰﾌﾞが目的ﾃﾞﾊﾞｲｽの適切なJTAGﾎﾟｰﾄ ﾋﾟﾝに配線されなければなりません。 特定ﾃﾞﾊﾞｲｽのJTAGﾋﾟﾝの位置については目的ﾃﾞﾊﾞｲｽのﾃﾞｰﾀｼｰﾄを調べてください。 下図はSTK500上のATmega32に対してﾋﾟﾝがどう接続されるべきかの例を示します。 RESETﾋﾟﾝがAVR Dragonから制御されるのなら、STK500上のRESETｼﾞｬﾝﾊﾟを取り去ることを思い出してください。

注 例えばSTK501/502のようなSTK500用のｱﾀﾞﾌﾟﾀ基板は専用のJTAGｺﾈｸﾀを持ちます

例: ATmega32でのSTK500へのAVR Dragon接続

図3-15.

STK500 JTAGｱﾀﾞﾌﾟﾀ

JTAGICEmkⅡと共に来るSTK500 JTAGｱﾀﾞﾌﾟﾀはSTK500上のSCKT3100A3とACKT3000D3のｿｹｯﾄと共にJTAGを持つAVRﾃﾞﾊﾞｲｽに対してSTK500への簡単な接続に使用できます。

図3-16.

JTAG許可ﾋｭｰｽﾞの許可

目的ﾃﾞﾊﾞｲｽ内のJTAG許可(JTAGEN)ﾋｭｰｽﾞが非ﾌﾟﾛｸﾞﾗﾑなら、JTAGｲﾝﾀｰﾌｪｰｽは禁止されます。 このﾋｭｰｽﾞはJTAGｲﾝﾀｰﾌｪｰｽを通してﾌﾟﾛｸﾞﾗﾐﾝｸﾞできず、従ってISPｲﾝﾀｰﾌｪｰｽ、高電圧直列または並列ｲﾝﾀｰﾌｪｰｽを通してﾌﾟﾛｸﾞﾗﾐﾝｸﾞされなければなりません。

ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽを通した目的対象への接続

ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽでのAVR Dragonと目的基板間の通信には最低3線が必要とされます。 これらの信号はRESET, VTref, GNDです。

重要! このｲﾝﾀｰﾌｪｰｽは目的対象との通信用に1ﾋﾟﾝ(RESETﾋﾟﾝ)だけを使用します。 AVRﾃﾞﾊﾞｲｽ上でﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽを許可するには、ﾃﾞﾊﾞｯｸﾞWIRE許可(DWEN)ﾋｭｰｽﾞがﾌﾟﾛｸﾞﾗﾑ(DWEN=0)されなければなりません。 ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽを持つAVRﾃﾞﾊﾞｲｽはDWENﾋｭｰｽﾞが非ﾌﾟﾛｸﾞﾗﾑ(1)で工場から出荷されます。 ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽそれ自身はこのﾋｭｰｽﾞを許可にできません。 このDWENﾋｭｰｽﾞは6ﾋﾟﾝ ﾍｯﾀﾞへの接続を必要とするISP動作を通してﾌﾟﾛｸﾞﾗﾐﾝｸﾞできます。 この理由に関して、ｴﾐｭﾚｰﾄとﾌﾟﾛｸﾞﾗﾐﾝｸﾞを容易にするために、目的基板上に完全な6ﾋﾟﾝ ｺﾈｸﾀを配置することが推奨されます。

注 DWENﾋｭｰｽﾞがﾌﾟﾛｸﾞﾗﾑ(0)されると、ISPｲﾝﾀｰﾌｪｰｽの通常機能は禁止されます。 これはﾃﾞﾊﾞｯｸﾞWIREがRESETﾋﾟﾝ全体を制御しなければならないからです。 DWENﾋｭｰｽﾞがﾌﾟﾛｸﾞﾗﾑ(0)されると、もやはISPを使用することはできません。 DWENﾋｭｰｽﾞを禁止するには、ﾃﾞﾊﾞｯｸﾞWIREまたは高電圧ﾌﾟﾛｸﾞﾗﾐﾝｸﾞを使用してください。

STK500上でAVR Dragonから、この接続を使用する場合、STK500上のRESETｼﾞｬﾝﾊﾟが非装着なことを保証してください。 そしてSTK500のｼﾙｸ印刷での色分けによって指示された実際のAVRﾃﾞﾊﾞｲｽに対する正しいISPﾍｯﾀﾞに接続してください。

AVR Dragon ﾃﾞﾊﾞｯｸﾞWIREｺﾈｸﾀ

図3-17.

図3-18. ﾋﾟﾝ配置

図3-19.

6芯ｹｰﾌﾞﾙを使用する6ﾋﾟﾝISPﾍｯﾀﾞへのAVR Dragonﾌﾟﾛｰﾌﾞ接続

DWENﾋｭｰｽﾞがﾌﾟﾛｸﾞﾗﾑ(0)されると、ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽを使用するためにGND, VTref, RESET線だけが必要とされます。 けれどもISP動作とﾃﾞﾊﾞｯｸﾞWIRE動作間の切り替え作業を容易にするために、全6線が接続されたﾃﾞﾊﾞｯｸﾞWIREが推奨されます。 AVR DragonはﾃﾞﾊﾞｯｸﾞWIRE走行時、自動的に全ての未使用ISPﾋﾟﾝをHi-Zにします。

ISPｲﾝﾀｰﾌｪｰｽの再許可

ISPｲﾝﾀｰﾌｪｰｽの再許可は以下の記述に従います。
  1. 上で記述されるようにISP(6ﾋﾟﾝ接続)でAVR Dragonを目的対象へ接続してください。
  2. (AVR StudioのDedugﾌﾟﾙﾀﾞｳﾝ ﾒﾆｭｰ下にある)"Start Debugging"命令を使用し、ﾌﾟﾛｼﾞｪｸﾄを読み込んでﾃﾞﾊﾞｯｸﾞ作業を開始してください。
  3. (AVR StudioのDedugﾌﾟﾙﾀﾞｳﾝ ﾒﾆｭｰ下にある)"AVR Dragon Options"を開き、"Connections"ﾀﾌﾞを選択してください。
  4. 下図で示されるように"disable DebugWIRE"釦をｸﾘｯｸしてください。 そして次のﾒｯｾｰｼﾞ ﾎﾞｯｸｽで"Yes"をｸﾘｯｸしてください。

図3-20.

注 ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽを渡る正しい通信を保証するために、RESET線に関係するいくつかの予防処置が講じられなければなりません。 RESET線にﾌﾟﾙｱｯﾌﾟがあるなら、この抵抗器は10KΩ以上でなければならず、且つ容量性負荷があるべきではありません。 このﾌﾟﾙｱｯﾌﾟ抵抗はﾃﾞﾊﾞｯｸﾞWIRE機能に対しては必要とされません。 RESET線に接続された他の論理回路は取り去られるべきです。

目的AVR上のﾛｯｸ ﾋﾞｯﾄがﾌﾟﾛｸﾞﾗﾑ(0)されている場合、ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽを使用することはできません。 DWENﾋｭｰｽﾞをﾌﾟﾛｸﾞﾗﾐﾝｸﾞする前にﾛｯｸ ﾋﾞｯﾄがｸﾘｱ(1)され、DWENﾋｭｰｽﾞがﾌﾟﾛｸﾞﾗﾑ(0)されている間、決してﾛｯｸ ﾋﾞｯﾄを設定(1)しないことを常に保証してください。 ﾃﾞﾊﾞｯｸﾞWIRE許可(DWEN)ﾋｭｰｽﾞとﾛｯｸ ﾋﾞｯﾄが共に設定(0)された場合、ﾁｯﾌﾟ消去を行うのに高電圧ﾌﾟﾛｸﾞﾗﾐﾝｸﾞを使用することができ、従って(それによって)ﾛｯｸ ﾋﾞｯﾄをｸﾘｱ(1)してください。 ﾛｯｸ ﾋﾞｯﾄがｸﾘｱ(1)されると、ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽは再び許可されます。

このISPｲﾝﾀｰﾌｪｰｽはDWENﾋｭｰｽﾞが非ﾌﾟﾛｸﾞﾗﾑ(1)にされるとき、ﾋｭｰｽﾞと識票の読み込みとﾁｯﾌﾟ消去を行うだけの能力です。

PDIｲﾝﾀｰﾌｪｰｽを通した目的対象への接続

PDIｲﾝﾀｰﾌｪｰｽでのAVR Dragonと目的基板間の通信のために最低2線が必要とされます。 PDI物性をご覧ください。 けれども6ﾋﾟﾝSPI形式ｺﾈｸﾀへの接続作業が容易なので、全6線接続でPDIを行うことが推奨されます。 AVR DragonはPDI動作時に全ての未使用ISPﾋﾟﾝを自動的にHi-Zにします。

AVR Dragon ﾃﾞﾊﾞｯｸﾞWIREｺﾈｸﾀ

図3-21.

図3-22.


AVR Dragon: ﾃﾞﾊﾞｲｽ接続ｼｰﾄ

ﾃﾞﾊﾞｲｽ接続ｼｰﾄ

SCKT3000D3 ﾃﾞﾊﾞｲｽ ｼｰﾄ

  • 支援ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ動作:
    • ISP
    • PP(並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ)
    • JTAGﾌﾟﾛｸﾞﾗﾐﾝｸﾞ
  • 支援ｴﾐｭﾚｰﾄ動作:
    • ﾌﾗｯｼｭ64kﾊﾞｲﾄ以下のﾃﾞﾊﾞｲｽに対してJTAG
  • 以下のﾃﾞﾊﾞｲｽに関して適用可:
    • ATmega8515 - 注: JTAGのﾌﾟﾛｸﾞﾗﾐﾝｸﾞとｴﾐｭﾚｰﾄはATmega8515で支援なし
    • ATmega162
以下の図はこれらﾃﾞﾊﾞｲｽのAVR Dragonへの接続方法を示します。

図3-23. 実装書き込み(ISP)
VCC
6 | B | NC | 5
4 | G | NC | 3
2 | NC | NC | 1

HV_PROG
20 | NC | NC | 19
18 | NC | NC | 17
16 | NC | NC | 15
14 | NC | NC | 13
12 | NC | NC | 11
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1
ISP
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
JTAG
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

ﾃﾞﾊﾞｲｽ
21 | NC | F | 20
22 | NC | NC | 19
23 | NC | NC | 18
24 | NC | NC | 17
25 | NC | NC | 16
26 | NC | NC | 15
27 | NC | NC | 14
28 | NC | NC | 13
29 | NC | NC | 12
30 | NC | NC | 11
31 | NC | NC | 10
32 | NC | E | 9
33 | NC | C | 8
34 | NC | A | 7
35 | NC | D | 6
36 | NC | NC | 5
37 | NC | NC | 4
38 | NC | NC | 3
39 | NC | NC | 2
40 | G | NC | 1

図3-24. 並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ (PP)
VCC
6 | U | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

HV_PROG
20 | T | S | 19
18 | R | Q | 17
16 | P | O | 15
14 | N | M | 13
12 | L | K | 11
10 | J | I | 9
8 | H | G | 7
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
ISP
6 | NC | NC | 5
4 | NC | NC | 3
2 | U | NC | 1
JTAG
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

ﾃﾞﾊﾞｲｽ
21 | NC | T | 20
22 | NC | Q | 19
23 | NC | NC | 18
24 | NC | P | 17
25 | NC | O | 16
26 | NC | N | 15
27 | NC | M | 14
28 | NC | L | 13
29 | NC | K | 12
30 | NC | J | 11
31 | NC | NC | 10
32 | NC | R | 9
33 | NC | H | 8
34 | NC | G | 7
35 | NC | F | 6
36 | NC | E | 5
37 | NC | D | 4
38 | NC | C | 3
39 | I | B | 2
40 | S | A | 1

図3-25. JTAGﾌﾟﾛｸﾞﾗﾐﾝｸﾞとJTAGｴﾐｭﾚｰﾄ
VCC
6 | D | H | 5
4 | I | NC | 3
2 | NC | NC | 1

HV_PROG
20 | NC | NC | 19
18 | NC | NC | 17
16 | NC | NC | 15
14 | NC | NC | 13
12 | NC | NC | 11
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1
ISP
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1
JTAG
10 | H | G | 9
8 | NC | NC | 7
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1

ﾃﾞﾊﾞｲｽ
21 | NC | B | 20
22 | NC | NC | 19
23 | NC | NC | 18
24 | A | NC | 17
25 | E | NC | 16
26 | C | NC | 15
27 | G | NC | 14
28 | NC | NC | 13
29 | NC | NC | 12
30 | NC | NC | 11
31 | NC | NC | 10
32 | NC | F | 9
33 | NC | NC | 8
34 | NC | NC | 7
35 | NC | NC | 6
36 | NC | NC | 5
37 | NC | NC | 4
38 | NC | NC | 3
39 | NC | NC | 2
40 | I | NC | 1

SCKT3100A3 ﾃﾞﾊﾞｲｽ ｼｰﾄ

  • 支援ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ動作:
    • ISP
    • PP(並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ)
    • JTAGﾌﾟﾛｸﾞﾗﾐﾝｸﾞ
  • 支援ｴﾐｭﾚｰﾄ動作:
    • ﾌﾗｯｼｭ64kﾊﾞｲﾄ以下のﾃﾞﾊﾞｲｽに対してJTAG
  • 以下のﾃﾞﾊﾞｲｽに関して適用可:
    • ATmega8535 - 注: JTAGのﾌﾟﾛｸﾞﾗﾐﾝｸﾞとｴﾐｭﾚｰﾄはATmega8535で支援なし
    • ATmega16
    • ATmega16A
    • ATmega164A
    • ATmega164P
    • ATmega164PA
    • ATmega32
    • ATmega32A
    • ATmega324A
    • ATmega324P
    • ATmega324PA
    • ATmega644
    • ATmega644A
    • ATmega644P
    • ATmega644PA
    • ATmega1284
    • ATmega1284P
以下の図はこれらﾃﾞﾊﾞｲｽのAVR Dragonへの接続方法を示します。

図3-26. 実装書き込み(ISP)
VCC
6 | B | NC | 5
4 | G | NC | 3
2 | NC | NC | 1

HV_PROG
20 | NC | NC | 19
18 | NC | NC | 17
16 | NC | NC | 15
14 | NC | NC | 13
12 | NC | NC | 11
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1
ISP
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
JTAG
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

ﾃﾞﾊﾞｲｽ
21 | NC | NC | 20
22 | NC | NC | 19
23 | NC | NC | 18
24 | NC | NC | 17
25 | NC | NC | 16
26 | NC | NC | 15
27 | NC | NC | 14
28 | NC | NC | 13
29 | NC | NC | 12
30 | NC | F | 11
31 | NC | G | 10
32 | NC | E | 9
33 | NC | C | 8
34 | NC | A | 7
35 | NC | D | 6
36 | NC | NC | 5
37 | NC | NC | 4
38 | NC | NC | 3
39 | NC | NC | 2
40 | NC | NC | 1

図3-27. 並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ (PP)
VCC
6 | U | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

HV_PROG
20 | T | S | 19
18 | R | Q | 17
16 | P | O | 15
14 | N | M | 13
12 | L | K | 11
10 | J | I | 9
8 | H | G | 7
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
ISP
6 | NC | NC | 5
4 | NC | NC | 3
2 | U | NC | 1
JTAG
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

ﾃﾞﾊﾞｲｽ
21 | P | O | 20
22 | NC | N | 19
23 | NC | M | 18
24 | NC | L | 17
25 | NC | K | 16
26 | NC | J | 15
27 | NC | NC | 14
28 | NC | Q | 13
29 | NC | NC | 12
30 | NC | T | 11
31 | NC | S | 10
32 | NC | R | 9
33 | NC | H | 8
34 | NC | G | 7
35 | NC | F | 6
36 | NC | E | 5
37 | NC | D | 4
38 | NC | C | 3
39 | NC | B | 2
40 | I | A | 1

図3-28. JTAGﾌﾟﾛｸﾞﾗﾐﾝｸﾞとJTAGｴﾐｭﾚｰﾄ
VCC
6 | D | H | 5
4 | I | NC | 3
2 | NC | NC | 1

HV_PROG
20 | NC | NC | 19
18 | NC | NC | 17
16 | NC | NC | 15
14 | NC | NC | 13
12 | NC | NC | 11
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1
ISP
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1
JTAG
10 | H | G | 9
8 | NC | NC | 7
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1

ﾃﾞﾊﾞｲｽ
21 | NC | NC | 20
22 | NC | NC | 19
23 | NC | NC | 18
24 | A | NC | 17
25 | E | NC | 16
26 | C | NC | 15
27 | G | NC | 14
28 | NC | NC | 13
29 | NC | NC | 12
30 | NC | B | 11
31 | NC | I | 10
32 | NC | F | 9
33 | NC | NC | 8
34 | NC | NC | 7
35 | NC | NC | 6
36 | NC | NC | 5
37 | NC | NC | 4
38 | NC | NC | 3
39 | NC | NC | 2
40 | NC | NC | 1

8.3. SCKT3200A2 ﾃﾞﾊﾞｲｽ ｼｰﾄ

  • 支援ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ動作:
    • ISP
    • PP(並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ)
  • 支援ｴﾐｭﾚｰﾄ動作:
    • ﾃﾞﾊﾞｯｸﾞWIRE
  • 以下のﾃﾞﾊﾞｲｽに関して適用可:
    • ATtiny48
    • ATtiny88
    • ATmega48
    • ATmega48A
    • ATmega48P
    • ATmega48PA
    • ATmega8 - 注: ﾃﾞﾊﾞｯｸﾞWIREはATmega8で支援なし
    • ATmega8A - 注: ﾃﾞﾊﾞｯｸﾞWIREはATmega8Aで支援なし
    • ATmega88
    • ATmega88A
    • ATmega88P
    • ATmega88PA
    • ATmega168
    • ATmega168A
    • ATmega168P
    • ATmega168PA
    • ATmega328
    • ATmega328P
以下の図はこれらﾃﾞﾊﾞｲｽのAVR Dragonへの接続方法を示します。

図3-29. 実装書き込み(ISP)とﾃﾞﾊﾞｯｸﾞWIREｴﾐｭﾚｰﾄ
VCC
6 | B | NC | 5
4 | G | NC | 3
2 | NC | NC | 1

HV_PROG
20 | NC | NC | 19
18 | NC | NC | 17
16 | NC | NC | 15
14 | NC | NC | 13
12 | NC | NC | 11
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1
ISP
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
JTAG
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

ﾃﾞﾊﾞｲｽ
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
15 | NC | NC | 14
16 | NC | NC | 13
17 | D | NC | 12
18 | A | NC | 11
19 | C | NC | 10
20 | NC | NC | 9
21 | NC | F | 8
22 | NC | G | 7
23 | NC | NC | 6
24 | NC | NC | 5
25 | NC | NC | 4
26 | NC | NC | 3
27 | NC | NC | 2
28 | NC | E | 1

図3-30. 並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ (PP)
VCC
6 | U | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

HV_PROG
20 | T | S | 19
18 | R | Q | 17
16 | P | O | 15
14 | N | M | 13
12 | L | K | 11
10 | J | I | 9
8 | H | G | 7
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
ISP
6 | NC | NC | 5
4 | NC | NC | 3
2 | U | NC | 1
JTAG
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

ﾃﾞﾊﾞｲｽ
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
15 | B | A | 14
16 | C | P | 13
17 | D | O | 12
18 | E | N | 11
19 | F | NC | 10
20 | NC | Q | 9
21 | NC | T | 8
22 | NC | S | 7
23 | G | M | 6
24 | H | L | 5
25 | I | K | 4
26 | NC | J | 3
27 | NC | NC | 2
28 | NC | R | 1

SCKT3300D3 ﾃﾞﾊﾞｲｽ ｼｰﾄ

  • 支援ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ動作:
    • ISP,
    • PP(並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ)
  • 支援ｴﾐｭﾚｰﾄ動作:
    • ﾃﾞﾊﾞｯｸﾞWIRE
  • 以下のﾃﾞﾊﾞｲｽに関して適用可:
    • ATtiny2313
    • ATtiny2313A
    • ATtiny4313
以下の図はこれらﾃﾞﾊﾞｲｽのAVR Dragonへの接続方法を示します。

図3-31. 実装書き込み(ISP)とﾃﾞﾊﾞｯｸﾞWIREｴﾐｭﾚｰﾄ
VCC
6 | B | NC | 5
4 | G | NC | 3
2 | NC | NC | 1

HV_PROG
20 | NC | NC | 19
18 | NC | NC | 17
16 | NC | NC | 15
14 | NC | NC | 13
12 | NC | NC | 11
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1
ISP
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
JTAG
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

ﾃﾞﾊﾞｲｽ
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
11 | NC | F | 10
12 | NC | NC | 9
13 | NC | NC | 8
14 | NC | NC | 7
15 | NC | NC | 6
16 | NC | NC | 5
17 | D | NC | 4
18 | A | NC | 3
19 | C | NC | 2
20 | G | E | 1

図3-32. 並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ (PP)
VCC
6 | U | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

HV_PROG
20 | T | S | 19
18 | R | Q | 17
16 | NC | O | 15
14 | N | M | 13
12 | L | K | 11
10 | J | NC | 9
8 | H | G | 7
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
ISP
6 | NC | NC | 5
4 | NC | NC | 3
2 | U | NC | 1
JTAG
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

ﾃﾞﾊﾞｲｽ
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
11 | O | T | 10
12 | A | N | 9
13 | B | M | 8
14 | C | L | 7
15 | D | K | 6
16 | E | Q | 5
17 | F | NC | 4
18 | G | J | 3
19 | H | NC | 2
20 | S | R | 1

SCKT3400D1 ﾃﾞﾊﾞｲｽ ｼｰﾄ

  • 支援ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ動作:
    • ISP
    • HVSP(高電圧直列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ)
  • 支援ｴﾐｭﾚｰﾄ動作:
    • ﾃﾞﾊﾞｯｸﾞWIRE
  • 以下のﾃﾞﾊﾞｲｽに関して適用可:
    • ATtiny11 - 注: ISPとﾃﾞﾊﾞｯｸﾞWIREはATtiny11で支援なし
    • ATtiny12 - 注: ﾃﾞﾊﾞｯｸﾞWIREはATtiny12で支援なし
    • ATtiny13
    • ATtiny13A
    • ATtiny25
    • ATtiny45
    • ATtiny85
以下の図はこれらﾃﾞﾊﾞｲｽのAVR Dragonへの接続方法を示します。

図3-33. 実装書き込み(ISP)とﾃﾞﾊﾞｯｸﾞWIREｴﾐｭﾚｰﾄ
VCC
6 | A | NC | 5
4 | G | NC | 3
2 | NC | NC | 1

HV_PROG
20 | NC | NC | 19
18 | NC | NC | 17
16 | NC | NC | 15
14 | NC | NC | 13
12 | NC | NC | 11
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1
ISP
6 | E | F | 5
4 | B | D | 3
2 | A | C | 1
JTAG
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

ﾃﾞﾊﾞｲｽ
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
5 | B | E | 4
6 | C | NC | 3
7 | D | NC | 2
8 | G | F | 1

図3-34. 高電圧直列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ (HVSP)
VCC
6 | A | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

HV_PROG
20 | H | G | 19
18 | F | E | 17
16 | NC | NC | 15
14 | NC | NC | 13
12 | NC | NC | 11
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | D | 3
2 | C | B | 1
ISP
6 | NC | NC | 5
4 | NC | NC | 3
2 | A | NC | 1
JTAG
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

ﾃﾞﾊﾞｲｽ
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
5 | B | H | 4
6 | C | NC | 3
7 | D | E | 2
8 | G | F | 1

SCKT3500D- ﾃﾞﾊﾞｲｽ ｼｰﾄ

  • 支援ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ動作:
    • PP(並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ)
  • 支援ｴﾐｭﾚｰﾄ動作:
    • なし
  • 以下のﾃﾞﾊﾞｲｽに関して適用可:
    • ATtiny28 - 注: ATtiny28については高電圧ﾌﾟﾛｸﾞﾗﾐﾝｸﾞのみ利用可
以下の図はこれらﾃﾞﾊﾞｲｽのAVR Dragonへの接続方法を示します。

図3-35. 並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ (PP)
VCC
6 | U | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

HV_PROG
20 | T | S | 19
18 | R | Q | 17
16 | NC | O | 15
14 | N | M | 13
12 | L | K | 11
10 | J | NC | 9
8 | H | G | 7
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
ISP
6 | NC | NC | 5
4 | NC | NC | 3
2 | U | NC | 1
JTAG
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

ﾃﾞﾊﾞｲｽ
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
15 | B | A | 14
16 | C | NC | 13
17 | D | O | 12
18 | E | N | 11
19 | F | NC | 10
20 | NC | Q | 9
21 | NC | NC | 8
22 | T | S | 7
23 | G | M | 6
24 | H | L | 5
25 | NC | K | 4
26 | NC | J | 3
27 | NC | NC | 2
28 | NC | R | 1

SCKT3600A1 ﾃﾞﾊﾞｲｽ ｼｰﾄ

  • 支援ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ動作:
    • ISP
    • HVSP(高電圧直列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ)
  • 支援ｴﾐｭﾚｰﾄ動作:
    • なし
  • 以下のﾃﾞﾊﾞｲｽに関して適用可:
    • ATtiny15 - 注: ｴﾐｭﾚｰﾄはATtiny15で支援なし
以下の図はこれらﾃﾞﾊﾞｲｽのAVR Dragonへの接続方法を示します。

図3-36. 実装書き込み(ISP)
VCC
6 | B | NC | 5
4 | G | NC | 3
2 | NC | NC | 1

HV_PROG
20 | NC | NC | 19
18 | NC | NC | 17
16 | NC | NC | 15
14 | NC | NC | 13
12 | NC | NC | 11
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1
ISP
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
JTAG
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

ﾃﾞﾊﾞｲｽ
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
5 | D | F | 4
6 | A | NC | 3
7 | C | NC | 2
8 | G | E | 1

図3-37. 高電圧直列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ (HVSP)
VCC
6 | H | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

HV_PROG
20 | G | F | 19
18 | E | D | 17
16 | NC | NC | 15
14 | NC | NC | 13
12 | NC | NC | 11
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | C | 3
2 | B | A | 1
ISP
6 | NC | NC | 5
4 | NC | NC | 3
2 | H | NC | 1
JTAG
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

ﾃﾞﾊﾞｲｽ
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
5 | A | G | 4
6 | B | D | 3
7 | C | NC | 2
8 | F | E | 1

SCKT3700A1 ﾃﾞﾊﾞｲｽ ｼｰﾄ

  • 支援ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ動作:
    • ISP
    • PP(並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ)
  • 支援ｴﾐｭﾚｰﾄ動作:
    • ﾃﾞﾊﾞｯｸﾞWIRE
  • 以下のﾃﾞﾊﾞｲｽに関して適用可:
    • ATtiny26 - 注: ﾃﾞﾊﾞｯｸﾞWIREはATtiny26で支援なし、PPﾌﾟﾛｸﾞﾗﾐﾝｸﾞの問題(既知の問題参照)
    • ATtiny261
    • ATtiny261A
    • ATtiny461
    • ATtiny461A
    • ATtiny861
    • ATtiny861A
以下の図はこれらﾃﾞﾊﾞｲｽのAVR Dragonへの接続方法を示します。

図3-38. 実装書き込み(ISP)とﾃﾞﾊﾞｯｸﾞWIREｴﾐｭﾚｰﾄ
VCC
6 | B | NC | 5
4 | G | NC | 3
2 | NC | NC | 1

HV_PROG
20 | NC | NC | 19
18 | NC | NC | 17
16 | NC | NC | 15
14 | NC | NC | 13
12 | NC | NC | 11
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1
ISP
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
JTAG
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

ﾃﾞﾊﾞｲｽ
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
11 | NC | E | 10
12 | NC | NC | 9
13 | NC | NC | 8
14 | NC | NC | 7
15 | NC | F | 6
16 | NC | G | 5
17 | NC | NC | 4
18 | NC | C | 3
19 | NC | A | 2
20 | NC | D | 1

図3-39. 並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ (PP)
VCC
6 | S | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

HV_PROG
20 | R | Q | 19
18 | P | O | 17
16 | N | M | 15
14 | L | K | 13
12 | J | I | 11
10 | NC | NC | 9
8 | H | G | 7
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
ISP
6 | NC | NC | 5
4 | NC | NC | 3
2 | S | NC | 1
JTAG
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

ﾃﾞﾊﾞｲｽ
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
11 | H | P | 10
12 | G | M | 9
13 | F | N | 8
14 | E | O | 7
15 | NC | R | 6
16 | NC | Q | 5
17 | D | L | 4
18 | C | K | 3
19 | B | J | 2
20 | A | I | 1

SCKT244484 ﾃﾞﾊﾞｲｽ ｼｰﾄ

  • 支援ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ動作:
    • ISP
    • HVSP(高電圧直列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ)
  • 支援ｴﾐｭﾚｰﾄ動作:
    • ﾃﾞﾊﾞｯｸﾞWIRE
  • 以下のﾃﾞﾊﾞｲｽに関して適用可:
    • ATtiny24
    • ATtiny24A
    • ATtiny44
    • ATtiny44A
    • ATtiny84
以下の図はこれらﾃﾞﾊﾞｲｽのAVR Dragonへの接続方法を示します。

図3-40. 実装書き込み(ISP)とﾃﾞﾊﾞｯｸﾞWIREｴﾐｭﾚｰﾄ
VCC
6 | B | NC | 5
4 | G | NC | 3
2 | NC | NC | 1

HV_PROG
20 | NC | NC | 19
18 | NC | NC | 17
16 | NC | NC | 15
14 | NC | NC | 13
12 | NC | NC | 11
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1
ISP
6 | F | E | 5
4 | D | C | 3
2 | B | A | 1
JTAG
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

ﾃﾞﾊﾞｲｽ
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
8 | A | D | 7
9 | C | NC | 6
10 | NC | NC | 5
11 | NC | E | 4
12 | NC | NC | 3
13 | NC | NC | 2
14 | F | G | 1

図3-41. 高電圧直列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ (HVSP)
VCC
6 | U | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

HV_PROG
20 | J | I | 19
18 | H | G | 17
16 | NC | NC | 15
14 | NC | NC | 13
12 | NC | F | 11
10 | E | D | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | C | 3
2 | B | A | 1
ISP
6 | NC | NC | 5
4 | NC | NC | 3
2 | U | NC | 1
JTAG
10 | NC | NC | 9
8 | NC | NC | 7
6 | NC | NC | 5
4 | NC | NC | 3
2 | NC | NC | 1

ﾃﾞﾊﾞｲｽ
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
 | NC | NC |
8 | B | A | 7
9 | C | NC | 6
10 | NC | NC | 5
11 | F | H | 4
12 | E | NC | 3
13 | D | G | 2
14 | I | J | 1

基板外目的対象 ﾃﾞﾊﾞｲｽ ｼｰﾄ

  • 支援ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ動作:
    • ISP
    • HVSP高電圧直列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ
    • PP並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ
    • JTAGﾌﾟﾛｸﾞﾗﾐﾝｸﾞ
  • 支援ｴﾐｭﾚｰﾄ動作:
    • ﾃﾞﾊﾞｯｸﾞWIRE
    • JTAG

このﾃﾞﾊﾞｲｽはPDIP外囲器が利用不能で、従ってAVR Dragonの試作領域へ直接的に接続できません。 ISP、HVSP、PP、JTAGに対する接続方法の情報については適切なﾃﾞｰﾀｼｰﾄをご覧ください。


AVR Dragon: ﾁｯﾌﾟ上ﾃﾞﾊﾞｯｸﾞ(OCD)の紹介

第4章 ﾁｯﾌﾟ上ﾃﾞﾊﾞｯｸﾞ

ﾁｯﾌﾟ上ﾃﾞﾊﾞｯｸﾞ(OCD)の紹介

伝統的なｴﾐｭﾚｰﾀは目的ﾃﾞﾊﾞｲｽの正確な動きの模倣を試みるﾂｰﾙです。 この動きが実際のﾃﾞﾊﾞｲｽの動きにより近いことが、より良いｴﾐｭﾚｰﾀです。 AVR Dragonは伝統的なｴﾐｭﾚｰﾀではありません。 代わりに、実行を制御して監視する機構を提供する、目的AVRﾃﾞﾊﾞｲｽ内部のﾁｯﾌﾟ上ﾃﾞﾊﾞｯｸﾞ ｼｽﾃﾑとAVR Dragonはｲﾝﾀｰﾌｪｰｽ接続をします。 この方法ではﾃﾞﾊﾞｯｸﾞされつつある応用はｴﾐｭﾚｰﾄされませんが、現実の目的AVRﾃﾞﾊﾞｲｽ上で実際に実行されます。 OCDｼｽﾃﾑとでの応用は、伝統的なｴﾐｭﾚｰﾀでは技術的に実現できない或る事、目的ｼｽﾃﾑに於いて正確な電気的及びﾀｲﾐﾝｸﾞの特性を維持すると同時に実行することができます。

走行動作(Run Mode)

走行動作時、ｺｰﾄﾞの実行はAVR Dragonと完全に独立です。 AVR Dragonは中断条件が起こるかを調べるために目的AVRを継続的に監視します。 これが起きると、OCDｼｽﾃﾑはﾃﾞﾊﾞｯｸﾞ ｲﾝﾀｰﾌｪｰｽを通してﾃﾞﾊﾞｲｽに質問し、ﾃﾞﾊﾞｲｽの内部状況を見るのを使用者に許します。

停止動作(Stopped Mode)

中断点(ﾌﾞﾚｰｸﾎﾟｲﾝﾄ)到達時、ﾌﾟﾛｸﾞﾗﾑ実行が停止され、全てのI/Oはまるで中断点が起きなかったかのように実行を継続します。 例えば中断点到達時にUSART送信が丁度開始されたと仮定します。 この場合は例えｺｰﾄﾞが停止動作でも、USARTは送信を完了する全速での走行を続けます。

ﾊｰﾄﾞｳｪｱ中断点

AVRのOCD部署はﾊｰﾄﾞｳｪｱで実装された多数のﾌﾟﾛｸﾞﾗﾑ ｶｳﾝﾀ比較器を含みます。 ﾌﾟﾛｸﾞﾗﾑ ｶｳﾝﾀがこの比較器ﾚｼﾞｽﾀの1つい格納された値と一致すると、OCDは停止動作へ移行します。 ﾊｰﾄﾞｳｪｱ中断点がOCD部署で専用のﾊｰﾄﾞｳｪｱを必要とするため、利用可能な中断点数は目的AVRで実装されたOCD部署の大きさに依存します。 一般的にﾊｰﾄﾞｳｪｱ比較器のようなものは内部使用に関してﾃﾞﾊﾞｯｶﾞによって"予約"されています。 様々なOCD部署で利用可能なﾊｰﾄﾞｳｪｱ中断点のより多くの情報については「OCDの実装」項をご覧ください。

ｿﾌﾄｳｪｱ中断点

ｿﾌﾄｳｪｱ中断点は目的ﾃﾞﾊﾞｲｽのﾌﾟﾛｸﾞﾗﾑ ﾒﾓﾘに置かれたBREAK命令です。 この命令が取得されると、ﾌﾟﾛｸﾞﾗﾑ実行が中断され、OCDは停止動作へ移行します。 実行を続けるにはOCDから"開始(start)"指令が与えられなければなりません。 全てのAVRﾃﾞﾊﾞｲｽがBREAK命令を支援するOCD部署を持っている訳ではありません。 様々なOCD部署で利用可能なｿﾌﾄｳｪｱ中断点のより多くの情報については「OCDの実装」項をご覧ください。

OCDｼｽﾃﾑ使用時の制限と考慮のより多くの情報については「特別な考慮」項をご覧ください。


AVR Dragon: 物理ｲﾝﾀｰﾌｪｰｽ

物理ｲﾝﾀｰﾌｪｰｽ

以降の項で記述されるようにAVR Dragonは多数のﾊｰﾄﾞｳｪｱ ｲﾝﾀｰﾌｪｰｽを支援します。

JTAG

JTAGｲﾝﾀｰﾌｪｰｽはIEEE 1149.1規格に準拠する4線検査入出力(TAP)制御器から成ります。 IEEE規格は回路基板結合を効率的に検査する工業標準の方法(境界走査)を提供するために開発されました。 ATMELのAVRﾃﾞﾊﾞｲｽは完全なﾌﾟﾛｸﾞﾗﾐﾝｸﾞとﾃﾞﾊﾞｯｸﾞ支援を含めるために、機能的にこれを拡張しています。

図4-1. JTAGｲﾝﾀｰﾌｪｰｽの基本

JTAGｲﾝﾀｰﾌｪｰｽを持つAVRを含む応用基板の設計時、図4-2. JTAGﾍｯﾀﾞ ﾋﾟﾝ配置で示されるようなﾋﾟﾝ配置を用いることが推奨されます。 AVR DragonのJTAGﾍｯﾀﾞはこのﾋﾟﾝ配置を支援します。

図4-2. JTAGﾍｯﾀﾞ ﾋﾟﾝ配置

表4-1. JTAGﾋﾟﾝ説明
名称 | ﾋﾟﾝ番号 | 意味
TCK | 1 | 検査ｸﾛｯｸ(AVR Dragonから目的ﾃﾞﾊﾞｲｽへのｸﾛｯｸ信号)。
TMS | 5 | 検査動作種別選択(AVR Dragonから目的ﾃﾞﾊﾞｲｽへの制御信号)。
TDI | 9 | 検査ﾃﾞｰﾀ入力(AVR Dragonから目的ﾃﾞﾊﾞｲｽへの送出ﾃﾞｰﾀ)。
TDO | 3 | 検査ﾃﾞｰﾀ出力(目的ﾃﾞﾊﾞｲｽからAVR Dragonへの送出ﾃﾞｰﾀ)。
nTRST | 8 | 検査ﾘｾｯﾄ(任意、いくつかのAVRﾃﾞﾊﾞｲｽでだけ)。 JTAG TAP制御器ﾘｾｯﾄに使用。
nSRST | 6 | 大元ﾘｾｯﾄ(任意)。 目的ﾃﾞﾊﾞｲｽのﾘｾｯﾄに使用。 或る筋書きでのﾃﾞﾊﾞｯｸﾞで本質的要素になり得る、例えば応用ﾌｧｰﾑｳｪｱによってJTDﾋﾞｯﾄが設定された場合のJTAGｲﾝﾀｰﾌｪｰｽ禁止、目的ﾃﾞﾊﾞｲｽをﾘｾｯﾄ状態に保持することをAVR Dragonで可能とするために、このﾋﾟﾝ接続が推奨されます。 nSRSTﾋﾟﾝはAVR Dragonに内部ﾌﾟﾙｱｯﾌﾟ抵抗を持ちます。
VTref | 4 | 目的対象基準電圧。 ﾚﾍﾞﾙ変換器での正しい供給のために、AVR Dragonはこのﾋﾟﾝ上で目的対象電圧を採取します。 AVR Dragonはこのﾋﾟﾝから1mA未満引き込みます。
GND | 2,10 | 接地。 AVR Dragonと目的ﾃﾞﾊﾞｲｽが同じ接地基準を共用するのを保証するために両方が接続されなければなりません。

助言: 2番ﾋﾟﾝと4番ﾋﾟﾝ間にﾃﾞｶｯﾌﾟ(雑音分離)ｺﾝﾃﾞﾝｻを含めることを憶えて置いてください。

注 AVR Dragonは目的対象によって給電することができません。 Vsupply(7番ﾋﾟﾝ)は未接続のままにすべきです。

外部回路が目的応用のJTAGﾃﾞﾊﾞｯｸﾞ線を共用する時に、図4-1. JTAGｲﾝﾀｰﾌｪｰｽの基本で示されるように、駆動部の衝突を避けるために直列抵抗が用いられるべきです。 抵抗値は外部回路とAVRがそれらの最大定格を越えないように(換言すると、多過ぎる吐き出しまたは吸い込み電流)選ばれるべきです。 1kΩが一般的に使用される値です。

(この抵抗の外側であるべき)これらの線のどのｱﾅﾛｸﾞ濾波器も、これらの要素がJTAG信号によって放電され、ｺﾝﾃﾞﾝｻの残留電圧によって影響された誤った論理ﾚﾍﾞﾙを引き起こす可能性のため、JTAG作業中にこれらは切断することが推奨されます。 濾波器が切断できない場合、安定電圧を維持するため、作業中にｺﾝﾃﾞﾝｻへ目的対象Vccの直接印加が推奨されます。 これを行う時にｺﾝﾃﾞﾝｻとJTAG線間に充分大きな抵抗を使用することに注意してください。

JTAGｲﾝﾀｰﾌｪｰｽは多数のﾃﾞﾊﾞｲｽに対してﾃﾞｨｰｼﾞｰﾁｪｰﾝ形態で単一ｲﾝﾀｰﾌｪｰｽへの接続を可能にします。 目的ﾃﾞﾊﾞｲｽは共通接地結線を共用して同じ供給電圧で全てが給電されなければならず、図4-3. JTAGﾃﾞｨｰｼﾞｰﾁｪｰﾝで示されるように接続されなければなりません。

図4-3. JTAGﾃﾞｨｰｼﾞｰﾁｪｰﾝ

ﾃﾞﾊﾞｲｽをﾃﾞｨｰｼﾞｰﾁｪｰﾝで接続する時に、以下の点が考慮されなければなりません。

  • 全ﾃﾞﾊﾞｲｽはAVR DragonのJTAGﾍｯﾀﾞのGNDへ接続された共通GNDを共用しなければなりません。
  • 全ﾃﾞﾊﾞｲｽは同じ目的電圧で動作しなければなりません。 AVR DragonのJTAGﾍｯﾀﾞのVTrefはこの電圧へ接続されなければなりません。
  • TMSとTCKは並列で接続され、TDIとTDOは直列ﾁｪｰﾝで接続されます。
  • ﾁｪｰﾝ内のﾃﾞﾊﾞｲｽのどれかがJTAGﾎﾟｰﾄを禁止する場合、AVR DragonのJTAGﾍｯﾀﾞのNSRSTはﾃﾞﾊﾞｲｽのRESETへ接続されなければなりません。
  • "Devices before"はTDI信号が目的ﾃﾞﾊﾞｲｽへ届く前にﾃﾞｨｰｼﾞｰﾁｪｰﾝを通らなければならない経路のJTAGﾃﾞﾊﾞｲｽ数を参照します。 同様に"devices after"はこの信号がAVR DragonのTDOﾋﾟﾝへ届く前に目的ﾃﾞﾊﾞｲｽ後に通らなければならない経路のﾃﾞﾊﾞｲｽ数です。
  • "Instruction bits before"と"Instruction bits after"はﾃﾞｨｰｼﾞｰﾁｪｰﾝでの目的ﾃﾞﾊﾞｲｽの前/後に接続される全JTAGﾃﾞﾊﾞｲｽの命令ﾚｼﾞｽﾀ(IR)長の総計を参照します。
  • ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ﾀﾞｲｱﾛｸﾞからのﾃﾞｨｰｼﾞｰﾁｪｰﾝ設定変更時、設定が有効になる前にﾀﾞｲｱﾛｸﾞが閉じられ、そして再び開かれなければならないことに注意してください。
  • 総IR長(Instruction bits before + AVRのIR長 + Instruction bits after)は最大32ﾋﾞｯﾄに制限されます。

ﾃﾞｨｰｼﾞｰﾁｪｰﾝ例: TDI⇒ATmega1280⇒ATxmega128A1⇒ATUC3A0512⇒TDO

XMEGAﾃﾞﾊﾞｲｽへ接続するためのﾃﾞｨｰｼﾞｰﾁｪｰﾝ設定は以下です。

Devices before | : | 1
Devices after | : | 1
Instruction bits before | : | 4 (AVRﾃﾞﾊﾞｲｽは4ﾋﾞｯﾄのIRを持ちます。)
Instruction bits before | : | 5 (AVR32ﾃﾞﾊﾞｲｽは5ﾋﾞｯﾄのIRを持ちます。)

PDI物性

ﾌﾟﾛｸﾞﾗﾐﾝｸﾞとﾃﾞﾊﾞｯｸﾞ用ｲﾝﾀｰﾌｪｰｽ(PDI)はﾃﾞﾊﾞｲｽの外部的なﾌﾟﾛｸﾞﾗﾐﾝｸﾞとﾃﾞﾊﾞｯｸﾞを行うためのATMELに所有権があるｲﾝﾀｰﾌｪｰｽです。 PDI物性は目的ﾃﾞﾊﾞｲｽと半二重双方向同期通信を提供する2ﾋﾟﾝのｲﾝﾀｰﾌｪｰｽです。

このｲﾝﾀｰﾌｪｰｽはA4系とより新しいXMEGAﾃﾞﾊﾞｲｽだけで支援されます。 完全な一覧については「支援ﾃﾞﾊﾞｲｽ」をご覧ください。

PDIｲﾝﾀｰﾌｪｰｽを持つAVRを含む応用基板の設計時、図4-4. PDIﾍｯﾀﾞ ﾋﾟﾝ配置で示されるﾋﾟﾝ配置が使用されるべきです。

図4-4. PDIﾍｯﾀﾞ ﾋﾟﾝ配置

注 上で示されたﾋﾟﾝ配置はSTK600、AVR ONE!、AVR Dragon、そしてPDIｲﾝﾀｰﾌｪｰｽを持つ将来のﾂｰﾙで共通です。 AVR Dragonは6芯ｹｰﾌﾞﾙを用いてSTK600へ直接的に接続されるかもしれません。

ﾃﾞﾊﾞｯｸﾞWIRE

ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽは少ﾋﾟﾝ数ﾃﾞﾊﾞｲｽでの使用に対してATMELによって開発されました。 4ﾋﾟﾝを使用するJTAGｲﾝﾀｰﾌｪｰｽのようではなく、ﾃﾞﾊﾞｯｸﾞWIREはﾃﾞﾊﾞｯｸﾞ ﾂｰﾙとの半二重双方向非同期通信に関して只単一のﾋﾟﾝ(RESET)を使用します。

ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽを持つAVRを含む応用基板の設計時、図4-4. ﾃﾞﾊﾞｯｸﾞWIRE(SPI)ﾍｯﾀﾞ ﾋﾟﾝ配置で示されるﾋﾟﾝ配置が用いられるべきです。

図4-4. ﾃﾞﾊﾞｯｸﾞWIRE(SPI)ﾍｯﾀﾞ ﾋﾟﾝ配置

注 ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽはﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ｲﾝﾀｰﾌｪｰｽとして使用することはできません。 これは目的対象をﾌﾟﾛｸﾞﾗﾐﾝｸﾞするために(図4-5. SPIﾍｯﾀﾞ ﾋﾟﾝ配置で示されるように)SPIｲﾝﾀｰﾌｪｰｽも利用可能でなければなりません。

ﾃﾞﾊﾞｯｸﾞWIRE許可(DWEN)ﾋｭｰｽﾞがﾌﾟﾛｸﾞﾗﾑ(0)され、ﾛｯｸ ﾋﾞｯﾄが非ﾌﾟﾛｸﾞﾗﾑ(1)にされる時に、目的ﾃﾞﾊﾞｲｽのﾃﾞﾊﾞｯｸﾞWIREｼｽﾃﾑが活動状態にされます。 RESETﾋﾟﾝはﾌﾟﾙｱｯﾌﾟ許可のANDﾀｲ(開放ﾄﾞﾚｲﾝ)双方向入出力ﾋﾟﾝとして形態設定され、目的対象とﾃﾞﾊﾞｯｶﾞ間の通信中継器になります。

SPI

実装ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ(書き込み)はﾌﾗｯｼｭ ﾒﾓﾘやEEPROM内にｺｰﾄﾞを格納するために目的AVRの内部SPI(直列周辺ｲﾝﾀｰﾌｪｰｽ)を使用します。 これはﾃﾞﾊﾞｯｸﾞ ｲﾝﾀｰﾌｪｰｽではありません。 SPIｲﾝﾀｰﾌｪｰｽを持つAVRを含む応用基板の設計時、図4-5. SPIﾍｯﾀﾞ ﾋﾟﾝ配置で示されるﾋﾟﾝ配置が用いられるべきです。

図4-5. SPIﾍｯﾀﾞ ﾋﾟﾝ配置


AVR Dragon: AVR OCD実装

AVR OCD実装

AVR XMEGA OCD(JTAGとPDIの物性)

XMEGAのOCDはPDI(ﾌﾟﾛｸﾞﾗﾐﾝｸﾞとﾃﾞﾊﾞｯｸﾞ用ｲﾝﾀｰﾌｪｰｽ)として別の方法で知られています。 あいにくAVR Dragonでの制限のため、より新しいXMEGAﾃﾞﾊﾞｲｽだけが支援されます。 「既知の問題」をご覧ください。 2つの物理ｲﾝﾀｰﾌｪｰｽ(JTAGとPDIの物性)はﾃﾞﾊﾞｲｽ内の同じOCD実装へのｱｸｾｽを提供します。 それは以下の機能を支援します。
  • 完全なﾌﾟﾛｸﾞﾗﾑの流れ制御
  • 1つの専用ﾌﾟﾛｸﾞﾗﾑ ｱﾄﾞﾚｽ比較器またはｼﾝﾎﾞﾘｯｸ中断点(予約)
  • 4つのﾊｰﾄﾞｳｪｱ比較器
  • 無制限数の(BREAKを使用する)使用者ﾌﾟﾛｸﾞﾗﾑ中断点
  • ｼｽﾃﾑ ｸﾛｯｸ周波数での制限なし
このﾃﾞﾊﾞｯｸﾞ ｲﾝﾀｰﾌｪｰｽに関する特別な考慮については「特別な考慮」をご覧ください。

AVR mega OCD(JTAG)

mega OCDはJTAG物理ｲﾝﾀｰﾌｪｰｽに基いています。 これは以下の機能を支援します。
  • 完全なﾌﾟﾛｸﾞﾗﾑの流れ制御
  • 4つのﾌﾟﾛｸﾞﾗﾑ ﾒﾓﾘ (ﾊｰﾄﾞｳｪｱ)中断点 (内1つは予約)
  • ﾃﾞｰﾀ中断点形式を兼ね備えることができるﾊｰﾄﾞｳｪｱ中断点
  • (BREAK命令使用で)無制限数のﾌﾟﾛｸﾞﾗﾑ中断点 (ATmega128(A)を除く)
このﾃﾞﾊﾞｯｸﾞ ｲﾝﾀｰﾌｪｰｽに関する特別な考慮については「特別な考慮」をご覧ください。

AVR mega/tiny OCD(ﾃﾞﾊﾞｯｸﾞWIRE)

ﾃﾞﾊﾞｯｸﾞWIRE OCDは少ﾋﾟﾝ数のAVRﾃﾞﾊﾞｲｽに対して特別に設計された、制限された機能の組を持つ特殊なOCD部です。 これは次の機能を支援します。
  • 完全なﾌﾟﾛｸﾞﾗﾑの流れ制御
  • (BREAK命令使用で)無制限数のﾌﾟﾛｸﾞﾗﾑ中断点
  • 目的対象ｸﾛｯｸに基く自動通信速度形態設定
このﾃﾞﾊﾞｯｸﾞ ｲﾝﾀｰﾌｪｰｽに関する特別な考慮については「特別な考慮」をご覧ください。


AVR Dragon: ﾊｰﾄﾞｳｪｱ説明

第5章 ﾊｰﾄﾞｳｪｱ説明

基板説明

  • 物理寸法(H×W×D) : 53×105×15mm

図5-1. 表面

図5-2. 裏面


AVR Dragon: ﾍｯﾀﾞ

ﾍｯﾀﾞ

AVR Dragonには枠から外れて配置された次の3つのｺﾈｸﾀがあります。
  • ISPﾍｯﾀﾞ - ISPﾌﾟﾛｸﾞﾗﾐﾝｸﾞとﾃﾞﾊﾞｯｸﾞWIRE内蔵ﾃﾞﾊﾞｯｸﾞ機能用に使用
  • JTAGﾍｯﾀﾞ - JTAGﾌﾟﾛｸﾞﾗﾐﾝｸﾞとJTAG内蔵ﾃﾞﾊﾞｯｸﾞ機能用に使用
  • VCCﾍｯﾀﾞ - 試作領域に配置されたﾃﾞﾊﾞｲｽへの給電、または外部目的基板電源用に使用 (最大300mA、5V固定設定)

図5-3.

次のﾍｯﾀﾞは実装されていません。

  • HV_PROGﾍｯﾀﾞ
  • EXPANDﾍｯﾀﾞ
  • 40ﾋﾟﾝDIPｿｹｯﾄ
  • 28ﾋﾟﾝDIPｿｹｯﾄ

ISPﾍｯﾀﾞ (実装済み)

この6ﾋﾟﾝﾍｯﾀﾞは外部目的対象へ容易に接続するための標準AVR ISPﾋﾟﾝ配列を使用します。 信号は1.8～5.5V間のどの電圧で走行する目的対象とも通信を許すためにﾚﾍﾞﾙ変換されます。

目的電圧がAVR Dragonのﾚﾍﾞﾙ変換器用にISPﾍｯﾀﾞの2ﾋﾟﾝへ印加されなければならないことに注意してください。

図5-4. ﾋﾟﾝ配置

JTAGﾍｯﾀﾞ (実装済み)

この10ﾋﾟﾝJTAGﾍｯﾀﾞは標準配列JTAGｺﾈｸﾀです。 AVR DragonのJTAGﾍｯﾀﾞを外部目的対象へ接続するとき、信号は目的基板電圧に合せるためにﾚﾍﾞﾙ変換されます。 これは自動的に行われます。 AVR DragonがJTAGｲﾝﾀｰﾌｪｰｽを通して目的対象に給電しないことに注意してください。 目的対象は専用電源を通して(またはVCCｺﾈｸﾀ(5.0V最大300mA)を使用して)給電される必要があります。 AVR DragonはJTAGｺﾈｸﾀの4ﾋﾟﾝでの目的電圧検出を必要とします。

図5-5. ﾋﾟﾝ配置

表5-1. ﾋﾟﾝ配置
ﾋﾟﾝ番号 | 信号名 | 入出力 | 説明
1 | TCK | 出力 | 検査ｸﾛｯｸ : AVR Dragonから目的JTAGﾎﾟｰﾄへのｸﾛｯｸ信号
2 | GND | - | 接地(GND)
3 | TDO | 入力 | 検査ﾃﾞｰﾀ出力 : 目的JTAGﾎﾟｰﾄからAVR Dragonへのﾃﾞｰﾀ信号
4 | VTref | 入力 | 目的基準電圧 : ﾚﾍﾞﾙ変換器を制御するために使用される目的対象からのVDD
5 | TMS | 出力 | 検査種別選択 : AVR Dragonから目的JTAGﾎﾟｰﾄへの動作種別選択信号
6 | nSRST | 入出力 | ｱﾀﾞﾌﾟﾀから目的ｼｽﾃﾑのﾘｾｯﾄへのｵｰﾌﾟﾝ ｺﾚｸﾀ出力。 このﾋﾟﾝは目的対象上のﾘｾｯﾄ開始をAVR Dragonへ報告できるようにするためのｱﾀﾞﾌﾟﾀへの入力でもあります。
7 | - | - | 未接続
8 | nTRST | NC (出力) | 未接続 : 他の装置との互換用予約 (JTAGﾎﾟｰﾄ ﾘｾｯﾄ)
9 | TDI | 出力 | 検査ﾃﾞｰﾀ入力 : AVR Dragonから目的JTAGﾎﾟｰﾄへのﾃﾞｰﾀ信号
10 | GND | - | 接地(GND)

HV_PROGﾍｯﾀﾞ (未実装)

このHV_PROGｺﾈｸﾀはHVSPとPPのﾌﾟﾛｸﾞﾗﾐﾝｸﾞを行うために必要とされる全ての信号を含みます。 このｺﾈｸﾀ上の信号はﾚﾍﾞﾙ変換されず、AVR Dragon上のEXPANDｺﾈｸﾀにだけ接続されるべきです。 外部目的基板上でHVSPまたはPPを行うことを試みた場合、AVR Dragonと目的対象の両方を損傷し得ます。 HV_PROGﾍｯﾀﾞ上の信号ﾚﾍﾞﾙは5Vです。

図5-6. 標準ﾋﾟﾝ配置

上図はHV_PROGﾍｯﾀﾞの一般的なﾋﾟﾝ配置を示します。 高電圧ﾌﾟﾛｸﾞﾗﾐﾝｸﾞのﾋﾟﾝ割り当ては全てのﾃﾞﾊﾞｲｽについて同じではありません。 このﾍｯﾀﾞのﾋﾟﾝ配置のより多くの情報については高電圧直列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ説明または並列ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ説明節をご覧ください。

VCCﾍｯﾀﾞ (実装済み)

図5-7. ﾋﾟﾝ配置

このVCCﾍｯﾀﾞはAVR Dragon基板の試作領域に配置された目的ﾃﾞﾊﾞｲｽに給電するために使用されなければならない、5.0VのVCCとGNDを含みます。 この電圧は外部目的基板への給電にも使用できますが、その消費電流は300mA以下であることが重要です。 AVR Dragonの供給の能力はﾎｽﾄUSB制御器が配給できる電流量によっても制限されることに注意してください。

EXPANDﾍｯﾀﾞ (未実装)

図5-8.

このEXPANDｺﾈｸﾀは28ﾋﾟﾝと40ﾋﾟﾝのDIPｿｹｯﾄに直接割り当てられます。 ｺﾈｸﾀ上の1番ﾋﾟﾝは28ﾋﾟﾝと40ﾋﾟﾝのDIPｿｹｯﾄの両方の1番ﾋﾟﾝです。 基板上でﾌﾟﾛｸﾞﾗﾐﾝｸﾞまたはｴﾐｭﾚｰﾄのどちらが行われる時も、適切な信号がISP, JTAG, VCC, HV_PROGﾍｯﾀﾞからEXPANDｺﾈｸﾀ上の正しいﾋﾟﾝに配線されるべきです。 この機能の使用法のより多くの情報については「基板上の試作領域」項を読んでください。

状態LED

図5-9.

2つのLEDがAVR Dragonの状態を示します。 何れの異常の場合も、解決法を調べるために「障害対策の指針」を調べてください。

表5-2.
LED番号 | 色 | 説明
2 | 緑 | USB通信表示
1 | 赤 | ｱｲﾄﾞﾙ状態 : AVR Ｓtudioに未接続
 | (消灯) | ｱｲﾄﾞﾙ状態 : AVR Ｓtudioに接続済み
 | 緑 | ﾃﾞｰﾀ転送中
 | 黄 | ﾌｧｰﾑｳｪｱ更新または初期化中


AVR Dragon: 基板上の試作領域

基板上の試作領域

図5-10.

AVR Dragonには28ﾋﾟﾝと40ﾋﾟﾝのPDIPｿｹｯﾄ用配線ﾊﾟﾀｰﾝがあります。 このDIPｿｹｯﾄのﾋﾟﾝは40ﾋﾟﾝ ﾍｯﾀﾞ ｺﾈｸﾀに直接的に接続されています。 ISP, JTAG, HV_PROG, VCCのﾍｯﾀﾞ信号を40ﾋﾟﾝ ﾍｯﾀﾞ ｺﾈｸﾀへ配線することによって、外部目的対象基板の必要なしにﾌﾟﾛｸﾞﾗﾐﾝｸﾞとｴﾐｭﾚｰﾄが実行できます。

本章は各種動作種別に対するAVR Dragonの配線方法を示します。 支援される各AVRﾃﾞﾊﾞｲｽには必要とする全情報を含むそれ自体の「ﾃﾞﾊﾞｲｽ接続ｼｰﾄ」があります。

試作領域を利用するには多くの方法があります。 1つのﾃﾞﾊﾞｲｽ形式/ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ動作だけが使用されるなら、最も簡単で安価な方法はISP, JTAG, HV_PROG, VCCのﾍｯﾀﾞからEXPANDﾍｯﾀﾞへ半田付けで線を直接配線することです。 けれども基板をより柔軟にするため、半田付けなしで接続するためのｹｰﾌﾞﾙ使用を許す、ﾍｯﾀﾞ ｺﾈｸﾀを半田付けすることができます。

ここはAVR Dragon基板を柔軟にし、且つAVRﾃﾞﾊﾞｲｽの全DIPｿｹｯﾄを使用できるようにするための修正方法の提案です

図5-11.

この図では1つの20ﾋﾟﾝ ﾍｯﾀﾞ ｺﾈｸﾀ、40ﾋﾟﾝ ﾍｯﾀﾞ ｺﾈｸﾀと40ﾋﾟﾝDIPｿｹｯﾄがAVR Dragon上に半田付けされています。

図5-12.

より柔軟で更に狭幅DIP外囲器についても許すために、ZIP(0挿入力)ｿｹｯﾄが上図で追加されています。 MLF/QFN, TQFP, SOICなどの外囲器を支援するための付加ｿｹｯﾄが他社の供給元から購入できます(ﾘﾝｸ: http://www.atmel.com/products/AVR/thirdparty.asp#adapters)。

図5-13.

そして最後にATtiny45のﾃﾞﾊﾞｯｸﾞWIREとﾌﾟﾛｸﾞﾗﾐﾝｸﾞ用の完全設定、この接続方法の詳細については「ATtiny45ﾃﾞﾊﾞｲｽ接続ｼｰﾄ」に目を通してください。


AVR Dragon: AVR Studio 4

第6章 統合ｿﾌﾄｳｪｱ

AVR Studio 4

統合AVR Studio 4

AVR Studio 4はWindows 9x/ME/NT/2000/XP/VISTA環境でAVR応用を書いてﾃﾞﾊﾞｯｸﾞするための統合開発環境(IDE)です。 AVR Studioはﾌﾟﾛｼﾞｪｸﾄ管理ﾂｰﾙ、ｿｰｽ ﾌｧｲﾙ ｴﾃﾞｨﾀ、ｼﾐｭﾚｰﾀ、ｱｾﾝﾌﾞﾗと、C/C++、ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ(書き込み)、ｴﾐｭﾚｰﾄ、ﾁｯﾌﾟ上ﾃﾞﾊﾞｯｸﾞ用の前処理部を提供します。

AVR Studio 4.09またはそれ以降がAVR Dragonと共に使用されなければなりません。

ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ任意選択

AVR Studio 4はAVR Dragonを用いるAVRﾃﾞﾊﾞｲｽのﾌﾟﾛｸﾞﾗﾐﾝｸﾞを支援します。 ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ﾀﾞｲｱﾛｸﾞは選んだ目的ﾃﾞﾊﾞｲｽに応じて、JTAG,SPI,PDI(選ばれたﾃﾞﾊﾞｲｽ)種別使用に形態設定することができます。

ｸﾛｯｸ周波数はSPIｲﾝﾀｰﾌｪｰｽに対してだけ形態設定することができます。 JTAGとPDI(選ばれたﾃﾞﾊﾞｲｽ)ｲﾝﾀｰﾌｪｰｽについてはﾌﾟﾛｸﾞﾗﾐﾝｸﾞが目的対象のｸﾛｯｸと非同期に行われます。

ﾃﾞﾊﾞｯｸﾞ任意選択

AVR Studio 4を使用してAVRﾃﾞﾊﾞｲｽをﾃﾞﾊﾞｯｸﾞする時に、AVR Dragon任意選択ﾀﾞｲｱﾛｸﾞはいくつかの重要な形態任意選択を含みます。 更なる説明を必要とするこれらの任意選択は以下です。
  • Target clock frequency
    目的ｸﾛｯｸ周波数: JTAGｲﾝﾀｰﾌｪｰｽでmega AVRﾃﾞﾊﾞｲｽの信頼に足るﾃﾞﾊﾞｯｸﾞを達成するには正確な目的ｸﾛｯｸ周波数設定が重要です。 この設定はﾃﾞﾊﾞｯｸﾞしようとする応用内の目的AVRﾃﾞﾊﾞｲｽの最低動作周波数を反映します。 より多くの情報については「特別な考慮 - mega OCD (JTAG)」項をご覧ください。

    ﾃﾞﾊﾞｯｸﾞWIRE目的ﾃﾞﾊﾞｲｽでのﾃﾞﾊﾞｯｸﾞ作業は目的ﾃﾞﾊﾞｲｽ自身によってｸﾛｯｸ駆動され、故に周波数設定は全く必要とされません。 AVR Dragonはﾃﾞﾊﾞｯｸﾞ作業の開始に於いて通信に関して正しいﾎﾞｰﾚｰﾄを自動的に選択します。

    XMEGA目的ﾃﾞﾊﾞｲｽはJTAGに対して最高速、PDI(選ばれたﾃﾞﾊﾞｲｽ)に対して1MHz一定ｸﾛｯｸでｸﾛｯｸ駆動されます。 XMEGAﾃﾞﾊﾞｲｽに関して同期が全く必要とされず、故にｸﾛｯｸは形態設定可能ではありません。

    * A4系とより新しいXMEGAﾃﾞﾊﾞｲｽだけを支援します。 完全な一覧については「支援ﾃﾞﾊﾞｲｽ」をご覧ください。

  • Disable debugWIRE
    ﾃﾞﾊﾞｯｸﾞWIRE禁止: DWENﾋｭｰｽﾞがﾌﾟﾛｸﾞﾗﾑ(0)されると、ﾃﾞﾊﾞｯｸﾞWIRE OCD部署がRESET線の制御を行います。 これはもはやSPIｲﾝﾀｰﾌｪｰｽがｱｸｾｽ可能でないことを意味します。 ﾃﾞﾊﾞｯｸﾞ中のDisable debugWIRE釦使用はﾃﾞﾊﾞｯｸﾞWIRE部署にそれ自身の一時的な禁止を指示し、従ってSPIﾌﾟﾛｸﾞﾗﾐﾝｸﾞを行うことを許します。

    SPIを用いてDWENが解除(1)される前に目的電力がOFF/ON切り替えされる場合、ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽが再許可されることに注意してください。

    SPIENﾋｭｰｽﾞが解除(1)されている場合、Disable debugWIRE釦はﾃﾞﾊﾞｯｸﾞWIREを一時的に禁止しますが、SPIｲﾝﾀｰﾌｪｰｽが許可されません。

    ﾃﾞﾊﾞｯｸﾞWIREの許可と禁止に関するより多くの情報については「特別な考慮 - ﾃﾞﾊﾞｯｸﾞWIRE OCD」項をご覧ください。

  • Run timers in stopped mode
    停止動作でﾀｲﾏ/ｶｳﾝﾀ走行。 この任意選択はｺｰﾄﾞを通して1行実行(ｼﾝｸﾞﾙ ｽﾃｯﾌﾟ)する時に、目的ﾃﾞﾊﾞｲｽのﾀｲﾏ/ｶｳﾝﾀに通常速度での継続走行を許します。 このﾁｪｯｸ ﾎﾞｯｸｽがﾁｪｯｸされないと、ﾀｲﾏ/ｶｳﾝﾀは正しい周期で走行しますが、ｺｰﾄﾞを通しての段階走行に同期されます。
  • Preserve EEPROM contents when reprogramming device
    ﾃﾞﾊﾞｯｸﾞ作業前に目的対象の再ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ(書き換え)中にEEPROMの消去を避けるには、この任意選択を選んでください。
  • Always activate external reset when reprogramming device
    目的応用がJTAGｲﾝﾀｰﾌｪｰｽを禁止する場合、ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ中に外部ﾘｾｯﾄはLowに引かれなければなりません。 この任意選択の選択は外部ﾘｾｯﾄ使用かを繰り返し問われるのを避けます。
  • Print breakpoint information in output window
    本機能許可はﾃﾞﾊﾞｯｸﾞ作業中にﾒｯｾｰｼﾞ出力ｳｨﾝﾄﾞｳへ中断点情報を吐き出させます。
  • Disable use of BREAK instruction for breakpoints
    AVR Dragonは目的対象のOCD部署が提供するのと同数のﾊｰﾄﾞｳｪｱ中断点を使用することができるだけです。 更なる比較器が利用不能のとき、AVR DragonはｺｰﾄﾞにBREAK命令を挿入します。 この機能は本ﾁｪｯｸ ﾎﾞｯｸｽをﾁｪｯｸすることによって禁止することができます。

    注意、手動で挿入されたBREAK命令はこの機能によって影響を及ぼされません。 手動で挿入されたBREAK命令を通り越すには、BREAK命令の下のｿｰｽ行で右ｸﾘｯｸし、"Set next statement"機能を使用してください。

  • Enable I/O Debug Register (IDR) in run mode
    ﾁｪｯｸ時、この任意選択はIDR事象出力にIDRとOSCCALに対して同じI/O位置を共用するﾃﾞﾊﾞｲｽを許します。 IDR事象は応用がIDRﾚｼﾞｽﾀへ書く時に生成されます。

    注 IDRはOCDRとしても知られ、ﾃﾞﾊﾞｯｸﾞWIRE OCDでは利用不能です。

  • PWM
    PWMﾀﾌﾞはAT90PWM2/3ﾃﾞﾊﾞｲｽに対してだけ活性(有効)です。 電力段制御器とｱﾅﾛｸﾞ比較器はﾃﾞﾊﾞｲｽが停止動作の時にも動作に形態設定することができます。

ﾌｧｰﾑｳｪｱ更新

準備については、ﾌｧｰﾑｳｪｱ更新準備

ﾌｧｰﾑｳｪｱ更新はAVR Studioを開始して、ToolsﾒﾆｭｰからTools⇒AVR Dragon Upgradeを選択することによって実行されます。

ﾌｧｰﾑｳｪｱ更新は「ｺﾏﾝﾄﾞ行からのﾌｧｰﾑｳｪｱ更新」項のｺﾏﾝﾄﾞ行ﾕｰﾃｨﾘﾃｨを使用しても達成することができます。


AVR Dragon: ｺﾏﾝﾄﾞ行ﾕｰﾃｨﾘﾃｨ

ｺﾏﾝﾄﾞ行ﾕｰﾃｨﾘﾃｨ

ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ

AVR Studio 4はAVR Dragonでのﾌﾟﾛｸﾞﾗﾐﾝｸﾞ作業を実行するためのｺﾏﾝﾄﾞ行ﾂｰﾙと共に出荷されます。 それは [ｲﾝｽﾄｰﾙ時のﾊﾟｽ\Atmel\AVR Tools\AvrDragon\avrdragon または等価な場所に置かれています。

使い方: avrdragon.exe [指令] [任意選択]

指令 :
-h, -? | 本ﾍﾙﾌﾟ表示。
-he | 終了符号表示。
-e | ﾁｯﾌﾟ消去。
-f <fusebytes> | 上位/下位ﾋｭｰｽﾞ ﾊﾞｲﾄ書き込み(XMEGAﾃﾞﾊﾞｲｽではﾋｭｰｽﾞ ﾊﾞｲﾄ1/0)。 <fusebytes>の下位ﾊﾞｲﾄが下位ﾋｭｰｽﾞ ﾊﾞｲﾄに書かれ、上位ﾊﾞｲﾄが上位ﾋｭｰｽﾞ ﾊﾞｲﾄに書かれます。
-j <ID> | JTAG ID読み出し。 任意のIDが指定された場合、読み出しIDと違うなら、ﾌﾟﾛｸﾞﾗﾑは終了します。
-l <lockbyte> | 施錠ﾋﾞｯﾄを指定値に設定します。
-p[f|e|b] | ﾌﾗｯｼｭ ﾒﾓﾘ(-pf)、EEPROM(-pe)、ﾌﾗｯｼｭ ﾒﾓﾘとEEPROM両方(-pb)の書き込み。 -if(ﾌﾗｯｼｭ ﾒﾓﾘ)、-ie(EEPROM)任意選択と共に指定された入力ﾌｧｲﾙが必要です。
-q | 全ﾋｭｰｽﾞ ﾊﾞｲﾄ読み出し。
-r[f|e|b] | ﾌﾗｯｼｭ ﾒﾓﾘ(-rf)、EEPROM(-re)、ﾌﾗｯｼｭ ﾒﾓﾘとEEPROM両方(-rb)の読み出し。 -of(ﾌﾗｯｼｭ ﾒﾓﾘ)、-oe(EEPROM)任意選択と共に指定された出力ﾌｧｲﾙが必要です。
-s | 識票ﾊﾞｲﾄ読み出し。
-v[f|e|b] | ﾌﾗｯｼｭ ﾒﾓﾘ(-vf)、EEPROM(-ve)、ﾌﾗｯｼｭ ﾒﾓﾘとEEPROM両方(-vb)の照合。 -if(ﾌﾗｯｼｭ ﾒﾓﾘ)、-ie(EEPROM)任意選択と共に指定された入力ﾌｧｲﾙが必要です。
-y | 施錠ﾋﾞｯﾄ読み出し。
-E <ext.fuse> | 拡張ﾋｭｰｽﾞ ﾊﾞｲﾄ(XMEGAﾃﾞﾊﾞｲｽではﾋｭｰｽﾞ ﾊﾞｲﾄ2)書き込み。
-F <fusebytes> | 上位/下位ﾋｭｰｽﾞ ﾊﾞｲﾄ照合。 <ext.fuse>の下位ﾊﾞｲﾄが下位ﾋｭｰｽﾞ ﾊﾞｲﾄと比較され、上位が上位ﾋｭｰｽﾞ ﾊﾞｲﾄと比較されます。
-L <lockbyte> | 施錠ﾋﾞｯﾄ照合。
-G <ext.fuse> | 与えられた値に対して拡張ﾋｭｰｽﾞ ﾊﾞｲﾄを照合。
-O <address> | 発振校正ﾊﾞｲﾄ読み出し。 <address>はﾃﾞﾊﾞｲｽのﾃﾞｰﾀｼｰﾄで指定されるﾊﾞｲﾄの位置です。
-S[f|e] <address> | -Oまたは-Zで読まれた発振器校正ﾊﾞｲﾄをﾌﾗｯｼｭ ﾒﾓﾘ(-Sf)またはEEPROM(-Se)で与えられた位置(<address>)へ書きます。
-W | ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽ禁止、ISP動作許可。 ﾃﾞﾊﾞｯｸﾞWIREﾃﾞﾊﾞｲｽでだけ利用可能です。
-Y | 発振器校正手順実行。 より多くの情報についてはAVR053応用記述をご覧ください。
-Z <address> | ﾃﾞﾊﾞｲｽ消去に先立ってEEPROMの(<address>)番地から値を取得します。 この値は-S[f|e]指令で再びEEPROMまたはﾌﾗｯｼｭ ﾒﾓﾘへ書くことができます。
任意選択 :
-ae <start>,<end> | EEPROM読み出しに対するｱﾄﾞﾚｽ範囲指定。 既定はﾒﾓﾘ全体。
-af <start>,<end> | ﾌﾗｯｼｭ ﾒﾓﾘ読み出しに対するｱﾄﾞﾚｽ範囲指定。 既定はﾒﾓﾘ全体。
-c <port> | 接続するﾎﾟｰﾄ指定。 USB, COM1～8, Auto(既定)にできます。 USBではｴﾐｭﾚｰﾀの通番を指定することもできます(-c USB:00A00000002C)。
-d <device> | [必須] ﾃﾞﾊﾞｲｽ型式指定。
-ie <file> | EEPROM書き込み用入力ﾌｧｲﾙ指定。
-if <file> | ﾌﾗｯｼｭ ﾒﾓﾘ書き込み用入力ﾌｧｲﾙ指定。
-m[i|j|p] | ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ種別選択 : ISP (-mi)、JTAG (-mj、既定)またはPDI(-mp).
-oe <file> | EEPROM読み出し用出力ﾌｧｲﾙ指定。
-of <file> | ﾌﾗｯｼｭ ﾒﾓﾘ読み出し用出力ﾌｧｲﾙ指定。
-z | 進捗表示なし。 ﾌｧｲﾙへのﾘﾀﾞｲﾚｸﾄ出力時に有用。
-D <devsbefore,devsafter,bitsbefore,bitsafter> | ﾃﾞｨｰｼﾞｰﾁｪｰﾝ設定。 JTAG動作でだけ利用可能。
-I <speed> | ISP周波数(Hz)指定。 ISP動作でだけ利用可能。
-J <speed> | ﾃﾞﾊﾞｲｽ速度(Hz)指定。 JTAG動作でだけ利用可能。
-R | ﾌﾟﾛｸﾞﾗﾐﾝｸﾞ中に外部ﾘｾｯﾄ印加。 JTAG動作でだけ利用可能。

使用例: avrdragon.exe -d ATxmega128 -e -pf -if c:\tmp\test.hex

ﾌｧｰﾑｳｪｱ更新

準備については、ﾌｧｰﾑｳｪｱ更新準備

ﾌｧｰﾑｳｪｱ更新はｺﾏﾝﾄﾞ行ﾕｰﾃｨﾘﾃｨ([ｲﾝｽﾄｰﾙ時のﾊﾟｽ]\Atmel\AVR Tools\AvrDragon\avrdragon.exe)を使用することによって達成できます。


AVR Dragon: XMEGA OCD

第7章 特別な考慮

XMEGA OCD

OCDとｸﾛｯｸ

MCUが停止動作に移行すると、MCUｸﾛｯｸとしてOCDｸﾛｯｸが使用されます。 OCDｸﾛｯｸはJTAGｲﾝﾀｰﾌｪｰｽが使用されている場合はJTAG TCK、またはPDIｲﾝﾀｰﾌｪｰｽが使用されている場合はPDI_CLKのどちらかです。

AVR DragonはXMEGA目的対象に対して可変ｸﾛｯｸ速度を提供しません。

停止動作でのSDRAM再活性(ﾘﾌﾚｯｼｭ)

OCDが停止動作の時は上の項で記述されるようにMCUはPDIまたはJTAGのｸﾛｯｸによってｸﾛｯｸ駆動されます。 ﾃﾞﾊﾞｯｶﾞまたはOCDでこの周波数を何も知らないので、自動的に低再活性周期($10)が使用されます。 この値は使用者によって変更できません。

停止動作でのI/O部署

殆どのATmegaﾃﾞﾊﾞｲｽと異なり、XMEGAのI/O部署は停止動作で停止します。 これはUSART送信が割り込まれ、ﾀｲﾏ(とPWM)が停止することを意味します。

ﾊｰﾄﾞｳｪｱ中断点

4つのﾊｰﾄﾞｳｪｱ中断点比較器、2つのｱﾄﾞﾚｽ比較器と2つの値比較器があります。 これらは或る制限を持っています。
  • 全ての中断点は同じ形式(ﾌﾟﾛｸﾞﾗﾑまたはﾃﾞｰﾀ)でなければなりません。
  • 全てのﾃﾞｰﾀ中断点は同じﾒﾓﾘ領域(I/O、SRAM、またはXRAM)でなければなりません。
  • ｱﾄﾞﾚｽ範囲が使用された場合、1つの中断点だけです。
以下は設定し得る異なる組み合わせです。
  • 2つの単一ﾃﾞｰﾀまたはﾌﾟﾛｸﾞﾗﾑ ｱﾄﾞﾚｽの中断点
  • 1つのﾃﾞｰﾀまたはﾌﾟﾛｸﾞﾗﾑ ｱﾄﾞﾚｽでの範囲中断点
  • 単一値比較付きの2つの単一ﾃﾞｰﾀ ｱﾄﾞｴｽ中断点
  • ｱﾄﾞﾚｽ範囲、値範囲、またはその両方付きの1つのﾃﾞｰﾀ中断点
AVR Studioは中断点が設定できない場合にそれと何故かを知らせます。 ｿﾌﾄｳｪｱ中断点が利用可能な場合、ﾃﾞｰﾀ中断点はﾌﾟﾛｸﾞﾗﾑ中断点より上の優先権を持ちます。

ﾃﾞｰﾀ中断点のﾍﾙﾌﾟはここで得られます。 けれども、全ての"中断時期(Break when)"任意選択がXMEGAで支援される訳ではありません。 また、EEPROMでのﾃﾞｰﾀ中断点は支援されません。

外部ﾘｾｯﾄとPDI物性

PDI物理ｲﾝﾀｰﾌｪｰｽはﾘｾｯﾄをｸﾛｯｸとして使用します。 ﾃﾞﾊﾞｯｸﾞ中、ﾘｾｯﾄのﾌﾟﾙｱｯﾌﾟは10kΩかまたはより高く、または全く取り去られるべきです。 どんなﾘｾｯﾄ ｺﾝﾃﾞﾝｻも取り去られるべきです。 他の外部ﾘｾｯﾄ元は切断されるべきです。


AVR Dragon: mega OCDとﾃﾞﾊﾞｯｸﾞWIRE OCD

mega OCDとﾃﾞﾊﾞｯｸﾞWIRE OCD

I/O周辺

例えﾌﾟﾛｸﾞﾗﾑ実行が中断点によって停止されても、I/O周辺の殆どは動作を継続します。 例: UART送信中に中断点に到達した場合、その送信は完了され、対応するﾋﾞｯﾄが設定(1)されます。 実際のﾃﾞﾊﾞｲｽでは本来後で起こる、TXC(送信完了)ﾌﾗｸﾞが設定(1)され、次のｺｰﾄﾞの1行実行が利用可能になります。

全てのI/O部署は次の2つの例外付きで停止動作に於いて動作を継続します。

  • ﾀｲﾏ/ｶｳﾝﾀ (ｿﾌﾄｳｪｱ前処理部使用で形態設定可能)
  • ｳｫｯﾁﾄﾞｯｸﾞ ﾀｲﾏ (ﾃﾞﾊﾞｯｸﾞ中のﾘｾｯﾄを防ぐため、常に停止)

1行実行I/Oｱｸｾｽ

停止動作でI/Oが動作を継続するので、或るﾀｲﾐﾝｸﾞの問題を避けるため、注意が祓われるべきです。 例えば、次のｺｰﾄﾞです。
OUT	PORTB,0xAA
IN	TEMP,PINB

このｺｰﾄﾞの通常走行時、TEMPﾚｼﾞｽﾀはIN命令によって採取される時によってﾃﾞｰﾀがﾋﾟﾝへ未だ物理的にﾗｯﾁされていないため、0xAAを読み戻しません。 PINﾚｼﾞｽﾀに正しい値が存在するのを保証するには、OUT命令とIN命令間にNOP命令が置かれなければなりません。

けれども、OCDを通してこの関数を1行実行すると、例え1行実行中にｺｰﾄﾞが停止しても、I/Oが全速で走行するため、このｺｰﾄﾞは常にPINﾚｼﾞｽﾀで0xAAを与えます。

1行実行とﾀｲﾐﾝｸﾞ

或るﾚｼﾞｽﾀは制御信号許可後に与えられた周期数内の読み書きを必要とします。 停止動作でI/Oｸﾛｯｸと周辺機能は全速での走行を続けるので、このようなｺｰﾄﾞを通る1行実行はﾀｲﾐﾝｸﾞ必要条件に遭いません。 2つの1行実行間でI/Oｸﾛｯｸは100万周回の走行になるかもしれません。 このようなﾀｲﾐﾝｸﾞ必要条件でのﾚｼﾞｽﾀ読み書き成功のため、読み書きの流れ全体は全速での非分断ﾃﾞﾊﾞｲｽ走行として実行されるべきです。 これはｺｰﾄﾞ実行にﾏｸﾛまたは関数呼び出しを使用、またはﾃﾞﾊﾞｯｸﾞ環境でｶｰｿﾙまで実行機能を使用することによって行うことができます。

16ﾋﾞｯﾄ ﾚｼﾞｽﾀのｱｸｾｽ

AVRの周辺機能は一般的に8ﾋﾞｯﾄのﾃﾞｰﾀ ﾊﾞｽ経由でｱｸｾｽできる各種16ﾋﾞｯﾄ ﾚｼﾞｽﾀを含みます(例えば、16ﾋﾞｯﾄ ﾀｲﾏ/ｶｳﾝﾀのTCNTn)。 16ﾋﾞｯﾄ ﾚｼﾞｽﾀは2つの読みまたは書きの操作を用いてﾊﾞｲﾄ入出力されなければなりません。 16ﾋﾞｯﾄ ｱｸｾｽの中間での中断や、この状況を通る1行実行は誤った値に終わるかもしれません。

I/Oﾚｼﾞｽﾀ ｱｸｾｽ制限

或るﾚｼﾞｽﾀはそれらの内容に影響を及ぼすことなく読むことができません。 このようなﾚｼﾞｽﾀは、読むことによって解除(0)されるﾌﾗｸﾞや、緩衝されるﾃﾞｰﾀ ﾚｼﾞｽﾀ(例えばUDR)のそれらを含みます。 加えて、いくつかのﾚｼﾞｽﾀは副次効果なしで安全に書くことができない、それらのﾚｼﾞｽﾀは読み込み専用。 例えば、
  • 何れかのﾋﾞｯﾄへの1書き込みによって解除(0)されるﾌﾗｸﾞのﾌﾗｸﾞ ﾚｼﾞｽﾀ。 これらのﾚｼﾞｽﾀは読み込み専用です。
  • UDRとSPDRのﾚｼﾞｽﾀはその部署の状態に影響を及ぼさずに読むことができません。 これらのﾚｼﾞｽﾀはｱｸｾｽ不能です。


AVR Dragon: mega OCD (JTAG)

mega OCD (JTAG)

ｿﾌﾄｳｪｱ中断点

それが初期のOCD部署を含むので、ATmega128(A)はｿﾌﾄｳｪｱ中断点に関してBREAK命令の使用を支援しません。

JTAGｸﾛｯｸ

目的対象ｸﾛｯｸ周波数はﾃﾞﾊﾞｯｸﾞ作業開始前にｿﾌﾄｳｪｱ前処理部に於いて正確に指定されなければなりません。 同期化の理由のため、JTAG TCK信号は信頼に足るﾃﾞﾊﾞｯｸﾞのために目的対象ｸﾛｯｸ周波数の1/4未満でなければなりません。 高すぎる目的ｸﾛｯｸ周波数設定はﾌﾟﾛｸﾞﾗﾐﾝｸﾞ完了の直ぐ後のﾃﾞﾊﾞｯｸﾞ作業失敗を引き起こすでしょう。 これは多数のSLEEP, WAKEUP, IDRのﾒｯｾｰｼﾞ表示を伴うかもしれません。 JTAGｲﾝﾀｰﾌｪｰｽ経由のﾌﾟﾛｸﾞﾗﾐﾝｸﾞ時、TCK周波数は目的ﾃﾞﾊﾞｲｽの評価最大周波数によって制限され、使用されている実際のｸﾛｯｸ周波数ではありません。

内蔵RC発振器使用時、周波数がﾃﾞﾊﾞｲｽ間で変わり、温度とVCCの変化によって影響されることに注意してください。 目的ｸﾛｯｸ周波数指定時、控え目にしてください。

ｿﾌﾄｳｪｱ前処理部を使用して目的ｸﾛｯｸ周波数を設定する方法の詳細については「統合ｿﾌﾄｳｪｱ」章をご覧ください。

JTAGENとOCDENのﾋｭｰｽﾞ

JTAGｲﾝﾀｰﾌｪｰｽはJTAGENﾋｭｰｽﾞを用いて許可され、これは既定でﾌﾟﾛｸﾞﾗﾑ(0)されています。 これはJTAGﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ｲﾝﾀｰﾌｪｰｽへのｱｸｾｽを許可します。 この機構を通して、OCDENﾋｭｰｽﾞをﾌﾟﾛｸﾞﾗﾑ(0)することができます(既定のOCDENは非ﾌﾟﾛｸﾞﾗﾑ(1)です)。 これはﾃﾞﾊﾞｲｽのﾃﾞﾊﾞｯｸﾞを容易にするためにOCDへのｱｸｾｽを許可します。 作業終了時にOCDENﾋｭｰｽﾞが非ﾌﾟﾛｸﾞﾗﾑ(1)のままにされ、これによってOCD部署による不要な電力消費を制止することを、常にｿﾌﾄｳｪｱ前処理部が保証します。 JTAGENﾋｭｰｽﾞが予期せず禁止された場合、SPIやPPのﾌﾟﾛｸﾞﾗﾐﾝｸﾞ法の使用でだけ再許可することができます。

JTAGENﾋｭｰｽﾞがﾌﾟﾛｸﾞﾗﾑ(0)されている場合、JTAGｲﾝﾀｰﾌｪｰｽはJTDﾋﾞｯﾄの設定(1)によってﾌｧｰﾑｳｪｱで未だ禁止することができます。 これはｺｰﾄﾞをﾃﾞﾊﾞｯｸﾞ不能にし、ﾃﾞﾊﾞｯｸﾞ作業を試みる時に行われるべきではありません。 ﾃﾞﾊﾞｯｸﾞ作業開始時にAVRﾃﾞﾊﾞｲｽでこのようなｺｰﾄﾞが既に実行する場合、AVR Dragonは接続中、/RESET線を活性(Low)にします。 この線が正しく配線されているなら、目的AVRﾃﾞﾊﾞｲｽをﾘｾｯﾄに強制し、これによってJTAG接続を許します。

JTAGｲﾝﾀｰﾌｪｰｽが許可された場合、JTAGﾋﾟﾝは切り替えﾋﾟﾝ機能用に使用することができません。 これらはJTDﾋﾞｯﾄの設定(1)によってﾌﾟﾛｸﾞﾗﾑ ｺｰﾄﾞから、またはﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ｲﾝﾀｰﾌｪｰｽを通してJTAGENﾋｭｰｽﾞを解除(1)することのどちらかによってJTAGｲﾝﾀｰﾌｪｰｽが禁止されるまでJTAGﾋﾟﾝ専用に留まります。

IDR事象

応用ﾌﾟﾛｸﾞﾗﾑがﾃﾞﾊﾞｯｸﾞ中のAVRﾃﾞﾊﾞｲｽのOCDRﾚｼﾞｽﾀへﾃﾞｰﾀ ﾊﾞｲﾄを書く時に、AVR Dragonがこの値を読み、ｿﾌﾄｳｪｱ前処理部のﾒｯｾｰｼﾞ ｳｨﾝﾄﾞｳでそれを出力表示します。 IDRﾚｼﾞｽﾀは100ms毎にﾎﾟｰﾘﾝｸﾞされ、故に高い頻度での書き込みは信頼に足る結果を齎さないでしょう。 ﾃﾞﾊﾞｯｸﾞ中にAVRﾃﾞﾊﾞｲｽが電力を失うと、偽のIDR事象が報告されるかもしれません。 これはAVR DragonがAVRの最低動作電圧以下の目的対象電圧低下として未だﾃﾞﾊﾞｲｽをﾎﾟｰﾘﾝｸﾞするために起きます。


AVR Dragon: ﾃﾞﾊﾞｯｸﾞWIRE OCD

ﾃﾞﾊﾞｯｸﾞWIRE OCD

ﾃﾞﾊﾞｯｸﾞWIRE通信(dW)ﾋﾟﾝは物理的に外部ﾘｾｯﾄ(/RESET)ﾋﾟﾝと同じﾋﾟﾝに配置されます。 従ってﾃﾞﾊﾞｯｸﾞWIRE許可時に外部ﾘｾｯﾄ元は支援されません。

ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽが機能するためには、目的ﾃﾞﾊﾞｲｽでﾃﾞﾊﾞｯｸﾞWIRE許可(DWEN)ﾋｭｰｽﾞが設定(0)されなければなりません。 このﾋｭｰｽﾞはAVRﾃﾞﾊﾞｲｽが工場から出荷される時に既定で非ﾌﾟﾛｸﾞﾗﾑ(1)です。 このﾋｭｰｽﾞの設定(0)にﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽ自身を用いることはできません。 DWENﾋｭｰｽﾞを設定(0)するためにはSPI動作が使用されなければなりません。 ｿﾌﾄｳｪｱ前処理部は必要なSPIﾋﾟﾝが接続された場合にこれを自動的に処理します。 AVR Studio 4のﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ﾀﾞｲｱﾛｸﾞからusing SPI programmingを設定することもできます。 ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽが機能するためには、目的ﾃﾞﾊﾞｲｽでﾃﾞﾊﾞｯｸﾞWIRE許可(DWEN)ﾋｭｰｽﾞが設定(0)されなければなりません。 このﾋｭｰｽﾞはAVRﾃﾞﾊﾞｲｽが工場から出荷される時に既定で非ﾌﾟﾛｸﾞﾗﾑ(1)です。 このﾋｭｰｽﾞの設定(0)にﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽ自身を用いることはできません。 DWENﾋｭｰｽﾞを設定(0)するためにはSPI動作が使用されなければなりません。 ｿﾌﾄｳｪｱ前処理部は必要なSPIﾋﾟﾝが接続された場合にこれを自動的に処理します。 AVR Studio 4のﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ﾀﾞｲｱﾛｸﾞからusing SPI programmingを設定することもできます。

  • 次の操作か: ﾃﾞﾊﾞｯｸﾞWIREﾃﾞﾊﾞｲｽでのﾃﾞﾊﾞｯｸﾞ作業開始を試みます。 ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽが許可されていない場合、AVR Studio 4で再試行を指示するか、またはSPIﾌﾟﾛｸﾞﾗﾐﾝｸﾞを用いてﾃﾞﾊﾞｯｸﾞWIRE許可を試みてください。 完全なSPIﾍｯﾀﾞ接続であるなら、ﾃﾞﾊﾞｯｸﾞWIREが許可され、目的対象の電源ON切り替えを問われるでしょう(これはﾋｭｰｽﾞ変更の効果のために必要とされます)。
  • または以下の操作: SPI動作でﾌﾟﾛｸﾞﾗﾐﾝｸﾞ ﾀﾞｲｱﾛｸﾞを開き、識票が正しいﾃﾞﾊﾞｲｽと一致することを照合してください。 ﾃﾞﾊﾞｯｸﾞWIREを許可するため、DWENﾋｭｰｽﾞを調べてください。

    注 SPIENﾋｭｰｽﾞがﾌﾟﾛｸﾞﾗﾑ(0)されるのと、RSTDISBLﾋｭｰｽﾞが非ﾌﾟﾛｸﾞﾗﾑ(1)にされることが重要です。 これを行わないことはﾃﾞﾊﾞｲｽをﾃﾞﾊﾞｯｸﾞWIRE動作で停止し、DWEN設定を復帰するには高電圧ﾌﾟﾛｸﾞﾗﾐﾝｸﾞが必要とされるでしょう。

ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽを禁止するには、DWENﾋｭｰｽﾞを非ﾌﾟﾛｸﾞﾗﾑ(1)にするのに高電圧ﾌﾟﾛｸﾞﾗﾐﾝｸﾞを使用してください。 代わりに、自身を一時的に禁止するのにﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽ自身を使用し、そしてこれはSPIENﾋｭｰｽﾞが設定(0)されているなら、SPIﾌﾟﾛｸﾞﾗﾐﾝｸﾞの実行を許します。

注 SPIENﾋｭｰｽﾞがﾌﾟﾛｸﾞﾗﾑ(0)のままにされない場合、AVR Studioはこの操作を完了できず、そして高電圧ﾌﾟﾛｸﾞﾗﾐﾝｸﾞが使用されなければなりません。

  • 次の操作か: ﾃﾞﾊﾞｯｸﾞ作業中、AVR Dragon任意選択ﾀﾞｲｱﾛｸﾞを開いてください。 disable debugWIRE釦をｸﾘｯｸしてください。 ﾃﾞﾊﾞｯｸﾞWIREが一時的に禁止され、DWENﾋｭｰｽﾞを非ﾌﾟﾛｸﾞﾗﾑ(1)にするのにAVR StudioはSPIﾌﾟﾛｸﾞﾗﾐﾝｸﾞを使用します。
  • または以下の操作: -W任意選択と共にｺﾏﾝﾄﾞ行ﾕｰﾃｨﾘﾃｨを使用してください。 ﾃﾞﾊﾞｯｸﾞWIREは一時的に禁止されます。 そしてDWENﾋｭｰｽﾞを非ﾌﾟﾛｸﾞﾗﾑ(1)にするのにSPIﾌﾟﾛｸﾞﾗﾐﾝｸﾞを使用してください。

    SPIを使用でDWENが解除(1)される前に目的対象電力が切り替えられた場合、ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽが再許可されることに注意してください。

ﾌﾟﾛｸﾞﾗﾑ(0)されたDWENﾋｭｰｽﾞを持つことは全てのｽﾘｰﾌﾟ動作での走行をｸﾛｯｸ系統のいくつかの部分に許します。 これはｽﾘｰﾌﾟ動作中のAVRの電力消費を増すでしょう。 従ってﾃﾞﾊﾞｯｸﾞWIREが使用されない時にDWENﾋｭｰｽﾞは常に禁止されるべきです。

ﾃﾞﾊﾞｯｸﾞWIREが使用される目的応用基板設計時、正しい動作のために以下の考慮がされなければなりません。

  • dW/(/RESET)線のﾌﾟﾙｱｯﾌﾟ抵抗は10kΩよりも小さくては(強力であっては)なりません。 ﾌﾟﾙｱｯﾌﾟ抵抗はﾃﾞﾊﾞｯｶﾞ ﾂｰﾙがこれを提供するので、機能的にﾃﾞﾊﾞｯｸﾞWIREに関して必要ではありません。
  • VCCへの/RESETﾋﾟﾝ直結はﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽに失敗を引き起こします。
  • /RESETﾋﾟﾝに接続されたどの安定化ｺﾝﾃﾞﾝｻも、それらがｲﾝﾀｰﾌｪｰｽの正しい動作を妨害するため、ﾃﾞﾊﾞｯｸﾞWIRE使用時に切断されなければなりません。
  • /RESET線の全ての外部ﾘｾｯﾄ元や他の活性ﾄﾞﾗｲﾊﾞは、それらがｲﾝﾀｰﾌｪｰｽの正しい動作を妨害するので、切断されなければなりません。
目的ﾃﾞﾊﾞｲｽの施錠ﾋﾞｯﾄを決してﾌﾟﾛｸﾞﾗﾑ(0)しないでください。 ﾃﾞﾊﾞｯｸﾞWIREｲﾝﾀｰﾌｪｰｽは正しい機能のために施錠ﾋﾞｯﾄが解除(1)されていることを必要とします。


AVR Dragon: 障害対策の指針

第8章 障害対策

障害対策の指針

表8-1. 障害対策の指針

問題点 | 理由 | 対処
識票ﾊﾞｲﾄを$00,$00,$00として読む。 | ISP周波数が高すぎる。 | 「基板設定」下でISP周波数をより低くしてください。
ﾃﾞﾊﾞｯｸﾞWIREを通してﾃﾞﾊﾞｲｽと通信できない。 | RESETﾌﾟﾙｱｯﾌﾟ抵抗値が小さすぎる。 | 取り去るか、またはﾌﾟﾙｱｯﾌﾟ値を10kΩ以上に増やしてください。
 | ﾃﾞｶｯﾌﾟ ｺﾝﾃﾞﾝｻがRESET線上の通信を妨害。 | ﾃﾞﾊﾞｯｸﾞWIREｴﾐｭﾚｰﾄ間はRESET線のﾃﾞｶｯﾌﾟ ｺﾝﾃﾞﾝｻを取り除いてください。
STK500使用時にﾃﾞﾊﾞｯｸﾞWIRE通信が失敗。 | RESET線がVCCへ強く結合されている。 | この線の制御をAVR Dragonに許すためにSTK500上のRESETｼﾞｬﾝﾊﾟを取り去ってください。
DWENﾋｭｰｽﾞ許可成功後、AVR Dragonがﾃﾞﾊﾞｯｸﾞ動作へ移行できない。
本基板上の目的対象に関して目的電圧を0Vとして読む。 | AVR Dragonが目的電圧検出の基準電圧を得られない。目的電圧はISPﾍｯﾀﾞの2ﾋﾟﾝかJTAGﾍｯﾀﾞの4ﾋﾟﾝのどちらかから検出されます。 | AVR Dragonのﾚﾍﾞﾙ変換器に基準電圧を得るには、VCCﾍｯﾀﾞの2,4,または6ﾋﾟﾝをISPﾍｯﾀﾞの2ﾋﾟﾝまたはJTAGﾍｯﾀﾞの4ﾋﾟﾝへ接続してください。 注: AVR DragonのVCCﾋﾟﾝは5Vに設定され、従って本処置は基板外目的対象に対して使用されるべきでないことに注意してください。
基板外の目的対象に関して目的電圧を0Vとして読む。 | AVR Dragonが目的電圧検出の基準電圧を得られない。目的電圧はISPﾍｯﾀﾞの2ﾋﾟﾝかJTAGﾍｯﾀﾞの4ﾋﾟﾝのどちらかから検出されます。 | 目的基板からの目的電圧をISPﾍｯﾀﾞの2ﾋﾟﾝまたはJTAGﾍｯﾀﾞの4ﾋﾟﾝへ接続してください。
ISP周波数が設定できない。 | AVR Dragonがどの目的電圧も読めない。 | 上記をご覧ください。
ISP/PP/HVSPﾌﾟﾛｸﾞﾗﾐﾝｸﾞが失敗する。 | AVR Dragonがどの目的電圧も読めない。 | 上記をご覧ください。
AVR Dragonが接続できず、状態LEDが黄点灯 | AVR Dragonのﾌｧｰﾑｳｪｱ更新失敗、またはﾌｧｰﾑｳｪｱが不正 | 手動更新を実行するには、ﾒﾆｭｰﾊﾞｰからTools⇒Upgrade AVR Dragonを行ってください。


AVR Dragon: ﾌｧｰﾑｳｪｱ更新

第9章 ﾌｧｰﾑｳｪｱ更新

準備

AVR Dragonはﾊﾞｸﾞ修正だけでなく新しいﾃﾞﾊﾞｲｽや系列の支援を提供するために利用可能となる新しいﾌｧｰﾑｳｪｱとして、最終使用者によって更新することができます。

更新を始める前に、動いているどのﾃﾞﾊﾞｯｸﾞ作業も終了し、ﾃﾞﾊﾞｯｸﾞしている応用から探針を切断することを確実にしてください。


AVR Dragon: 実行

実行

AVR Dragonのﾌｧｰﾑｳｪｱを更新するためには正しくｲﾝｽﾄｰﾙされたｿﾌﾄｳｪｱが必要です。 ﾌｧｰﾑｳｪｱ更新のより多くの情報についてはｿﾌﾄｳｪｱで補助された「ﾌｧｰﾑｳｪｱ更新」項をご覧ください。


AVR Dragon: 索引

索引

C

接続, AVR Dragonの接続

D

ﾃﾞﾊﾞｯｸﾞWIRE, ﾃﾞﾊﾞｯｸﾞWIRE

J

JTAG, JTAG

O

OCD, ﾁｯﾌﾟ上ﾃﾞﾊﾞｯｸﾞ(OCD)の紹介
AVR MEGA, AVR Mega OCD (JTAG)
AVR Mega
AVR Tiny, AVR mega/tiny OCD(ﾃﾞﾊﾞｯｸﾞWIRE)
AVR XMEGA, AVR XMEGA OCD(JTAGとPDIの物性)

S

特別な考慮, 特別な考慮
Mega, mega OCDとﾃﾞﾊﾞｯｸﾞWIRE OCD
debugWIRE, ﾃﾞﾊﾞｯｸﾞWIRE OCD
JTAG, mega OCD (JTAG)
XMEGA, XMEGA OCD
SPI, SPI

T

障害対策, 障害対策の指針